ssl mag mich nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

ssl mag mich nicht

Postby geiercasi » 21. February 2008 00:49

guten abend zusammen,

unter suse10.3 mag der indianer meine ssl config nicht. nach folgender anleitung ging ich vor:http://www.broschart.net/https-funktion-und-einrichtung/
nur das per cacert.org das .crt generiert wurde.
so schaut die conf aus:
<IfDefine SSL>
<IfDefine !NOSSL>

##
## SSL Virtual Host Context
##

<VirtualHost webmail.server.wunschradio.de:443>

# General setup for the virtual host
DocumentRoot "/srv/www/htdocs/squirrelmail"
ServerName webmail.server.wunschradio.de:443
ServerAdmin ichmagkeinerspamer@chatlabel.de
ErrorLog ErrorLog /var/log/apache2/domains/webmail.server.wunschradio.de.error.log
TransferLog /var/log/apache2/access_log

# SSL Engine Switch:
# Enable/Disable SSL for this virtual host.
SSLEngine on

# SSL Cipher Suite:
# List the ciphers that the client is permitted to negotiate.
# See the mod_ssl documentation for a complete list.
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL

SSLCertificateFile /etc/apache2/ssl.crt/webmail.server.wunschradio.de.crt

SSLCertificateKeyFile /etc/apache2/ssl.key/webmail.server.wunschradio.de.key

<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
<Directory "/srv/www/cgi-bin">
SSLOptions +StdEnvVars
</Directory>

SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0
CustomLog /var/log/apache2/ssl_request_log ssl_combined

</VirtualHost>

</IfDefine>
</IfDefine>

der gute lässt sich problemlos neu starten. aufruf von https://webmail.server.wunschradio.de scheitert. fehlermedung steht keine im log...

kann mir bitte jemand auf die sprünge helfen ?

gruß und danke
geiercasi
 
Posts: 3
Joined: 21. February 2008 00:43

Postby Wiedmann » 21. February 2008 01:06

so schaut die conf aus:

Diese Konfigurationsdatei wird auch geladen?

Code: Select all
<IfDefine SSL>
<IfDefine !NOSSL>

Der Apache wird mit dem Parameter SSL gestartet, und NOSSL ist icht gesetzt?

aufruf von "https://webmail.server.wunschradio.de" scheitert.

- Funktioniert die Namensauflösung direkt auf dem Server mit diesem Hostnamen?
- Firewall lässt diesen Port zu?
- Bindet sich der Apache auf dem Port 443 an eine IP (welche?)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby geiercasi » 21. February 2008 01:10

hallo wiedmann, danke für deine antwort.

firewall ist keine aktiv
namensauflösung funktioniert
was meinst du mit nossl ist nicht gesetzt ?
ich gehe mal davon aus, das diese conf auch geladen wird, da ein rcapache start keine fehler ausgibt.
der apache wird mit 443 an keine ip gebunden.
update:
jetzt ist er zusätzlich zum port 80 gebunden. apache start gibt diesen fehler:
Starting httpd2 (prefork) [Thu Feb 21 01:10:51 2008] [warn] NameVirtualHost 85.214.63.178:443 has no VirtualHosts

gruß
geiercasi
 
Posts: 3
Joined: 21. February 2008 00:43

Postby Wiedmann » 21. February 2008 01:27

namensauflösung funktioniert

Welche IP wird dann bei einem "nslookup webmail.server.wunschradio.de" auf dem Server ausgegeben?

was meinst du mit nossl ist nicht gesetzt ?

Wenn "NOSSL" beim Apachestart gesetzt ist, wird diese Konfiguration nicht beachtet (ebenso wenn "SSL" nicht gesetzt ist).

ch gehe mal davon aus, das diese conf auch geladen wird, da ein rcapache start keine fehler ausgibt.

Eine Datei mit Fehler erzeugt keinen Fehler, wenn sie erst gar nicht benutzt/geladen wird ;-)

Schreib doch einfach mal das Wort "Fehler" ganz an den Anfang dieser Datei, und starte dann den Apachen neu (und beim nächsten Test innerhalb dach den "IfDefine"-Directiven).

update: jetzt ist er zusätzlich zum port 80 gebunden. apache start gibt diesen fehler:

Was hast du gemacht, das diese Veränderung im Verhalten verursacht hat?

Code: Select all
Starting httpd2 (prefork) [Thu Feb 21 01:10:51 2008] [warn] NameVirtualHost 85.214.63.178:443 has no VirtualHosts

In dem von dir geposteten Code tauch die Directive "NameVirtualHost" nirgends auf. Wo kommt diese her? (BTW funktioniert SSL sowieso nicht korrekt mit namebased VHosts.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby geiercasi » 21. February 2008 08:14

diese ip zeigt auf webmail.server.wunschradio.de 85.214.63.178.
nossl werde ich dann mal aus der conf werfen.
beim test in der conf (am anfang zickt er über das test.
den fehler (443 hat keine virtuellen hosts) zeigt er, seit in der httpd.conf zuätzlich zum
NameVirtualHost 85.214.63.178:80
dieser eintrag steht
NameVirtualHost 85.214.63.178:443 < der ist nun wieder entfernt

soll ich den indianer jetzt fürs webmail an eine zusätzliche ip binden, damit das funktioniert ?

gruß und danke für deine mühe
geiercasi
 
Posts: 3
Joined: 21. February 2008 00:43


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests