mod_rewrite Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

mod_rewrite Problem

Postby tutaeks » 14. February 2008 13:25

Hallo erst einmal!


Ich habe folgendes Problem:

Ich habe in meiner phpinfo stehen das bei
Loaded Modules: core mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_dir mod_env mod_include mod_mime mod_python mod_negotiation mod_perl mod_php5 mod_rewrite mod_setenvif mod_ssl mod_status mod_suexec

D.h. ja dann das mod_rewrite "gestartet" ist.

Habe jetzt mal in der .htaccess "RewriteBase /" hin zu gefügt.
Aber läuft immer noch nicht:-(

Hier mal meine .htaccess:
RewriteEngine on
RewriteBase /
RewriteRule ^profil/(.*)/$ index.php?d=profil&s=$1
RewriteRule ^profil/(.*)$ index.php?d=profil&s=$1
RewriteRule ^login/(.*)/(.*)/$ index.php?d=login&s=$1&u=$2
RewriteRule ^login/(.*)/(.*)$ index.php?d=login&s=$1&u=$2
RewriteRule ^login/(.*)/$ index.php?d=login&s=$1
RewriteRule ^login/(.*)$ index.php?d=login&s=$1
RewriteRule ^fotoalbum/(.*)/$ index.php?d=fotoalbum&a=$1
RewriteRule ^fotoalbum/(.*)$ index.php?d=fotoalbum&a=$1
RewriteRule ^alben/(.*)/$ index.php?d=alben&a=$1
RewriteRule ^alben/(.*)$ index.php?d=alben&a=$1
RewriteRule ^gruppenmitglieder/(.*)/$ index.php?d=gruppenmitglieder&a=$1
RewriteRule ^gruppenmitglieder/(.*)$ index.php?d=gruppenmitglieder&a=$1
RewriteRule ^freunde/(.*)/$ index.php?d=freunde&a=$1
RewriteRule ^freunde/(.*)$ index.php?d=freunde&a=$1
RewriteRule ^gaestebuch/(.*)/$ index.php?d=gaestebuch&a=$1
RewriteRule ^gaestebuch/(.*)$ index.php?d=gaestebuch&a=$1
RewriteRule ^forum/(.*)/(.*)/$ index.php?d=forum&s=$1&u=$2
RewriteRule ^forum/(.*)/(.*)$ index.php?d=forum&s=$1&u=$2
RewriteRule ^gruppen/(.*)/(.*)/$ index.php?d=gruppen&s=$1&u=$2
RewriteRule ^gruppen/(.*)/(.*)$ index.php?d=gruppen&s=$1&u=$2
RewriteRule ^blog/(.*)/rss/$ rss.php?u=$1
RewriteRule ^blog/(.*)/rss$ rss.php?u=$1
RewriteRule ^blog/(.*)/(.*)/$ index.php?d=blog&u=$1&e=$2
RewriteRule ^blog/(.*)/(.*)$ index.php?d=blog&u=$1&e=$2
RewriteRule ^blog/(.*)/$ index.php?d=blog&u=$1
RewriteRule ^blog/(.*)$ index.php?d=blog&u=$1
RewriteRule ^d/(.*)/$ index.php?d=$1
RewriteRule ^d/(.*)$ index.php?d=$1

Kann das sein das da hinter die RewriteBase noch was muss?


mfg
Thorsten

PS: Auf einem anderen Server läuft es.
tutaeks
 
Posts: 11
Joined: 23. September 2004 19:29
Location: Essen

Postby Scory » 14. February 2008 16:18

Woran siehst Du, dass es "nicht" läuft?
Scory
 

Postby tutaeks » 14. February 2008 16:31

Weil die Seite dann so aussieht, wie sie jetzt aussieht;-)

www.freundewelt.de

Die Aktuelle .htaccess:
RewriteEngine on
RewriteRule ^profil/([^/]*)/$ index.php?d=profil&s=$1
RewriteRule ^profil/([^/]*)$ index.php?d=profil&s=$1
RewriteRule ^login/([^/]*)/([^/]*)/$ index.php?d=login&s=$1&u=$2
RewriteRule ^login/([^/]*)/([^/]*)$ index.php?d=login&s=$1&u=$2
RewriteRule ^login/([^/]*)/$ index.php?d=login&s=$1
RewriteRule ^login/([^/]*)$ index.php?d=login&s=$1
RewriteRule ^fotoalbum/([^/]*)/$ index.php?d=fotoalbum&a=$1
RewriteRule ^fotoalbum/([^/]*)$ index.php?d=fotoalbum&a=$1
RewriteRule ^alben/([^/]*)/$ index.php?d=alben&a=$1
RewriteRule ^alben/([^/]*)$ index.php?d=alben&a=$1
RewriteRule ^gruppenmitglieder/([^/]*)/$ index.php?d=gruppenmitglieder&a=$1
RewriteRule ^gruppenmitglieder/([^/]*)$ index.php?d=gruppenmitglieder&a=$1
RewriteRule ^freunde/([^/]*)/$ index.php?d=freunde&a=$1
RewriteRule ^freunde/([^/]*)$ index.php?d=freunde&a=$1
RewriteRule ^gaestebuch/([^/]*)/$ index.php?d=gaestebuch&a=$1
RewriteRule ^gaestebuch/([^/]*)$ index.php?d=gaestebuch&a=$1
RewriteRule ^forum/([^/]*)/([^/]*)/$ index.php?d=forum&s=$1&u=$2
RewriteRule ^forum/([^/]*)/([^/]*)$ index.php?d=forum&s=$1&u=$2
RewriteRule ^gruppen/([^/]*)/([^/]*)/$ index.php?d=gruppen&s=$1&u=$2
RewriteRule ^gruppen/([^/]*)/([^/]*)$ index.php?d=gruppen&s=$1&u=$2
RewriteRule ^blog/([^/]*)/rss/$ rss.php?u=$1
RewriteRule ^blog/([^/]*)/rss$ rss.php?u=$1
RewriteRule ^blog/([^/]*)/([^/]*)/$ index.php?d=blog&u=$1&e=$2
RewriteRule ^blog/([^/]*)/([^/]*)$ index.php?d=blog&u=$1&e=$2
RewriteRule ^blog/([^/]*)/$ index.php?d=blog&u=$1
RewriteRule ^blog/([^/]*)$ index.php?d=blog&u=$1
RewriteRule ^d/([^/]*)/$ index.php?d=$1
RewriteRule ^d/([^/]*)$ index.php?d=$1


mfg
Thorsten
tutaeks
 
Posts: 11
Joined: 23. September 2004 19:29
Location: Essen

Postby tutaeks » 14. February 2008 17:04

Ich nehme bald mal an das es nicht ausreicht wenn das Modul mod_rewrite nur geladen ist.

Muss dann noch vielleicht was anderes geladen sein, oder in der Server Konfiguration stehen?


mfg
Thorsten
tutaeks
 
Posts: 11
Joined: 23. September 2004 19:29
Location: Essen

Postby Scory » 14. February 2008 19:18

>Ich nehme bald mal an das es nicht ausreicht wenn das Modul mod_rewrite nur geladen ist.

Vielleicht.

>Muss dann noch vielleicht was anderes geladen sein, oder in der Server Konfiguration stehen?

Vielleicht.

Kannst Du eigentlich Gedanken lesen? Ich nämlich nicht - und bisher hast Du noch kein Sterbenswörtchen darüber verloren, was ggf. irgendwo nicht funktioniert. Die Seite geht - das ist alles, was ich sehe.
Scory
 

Postby tutaeks » 14. February 2008 19:25

Ja, jetzt im moment habe ich auch mod_rewrite deaktiviert.

Es kommt eine 403 meldung und man kommt nicht auf die Seite.

Lasse die Seite jetzt nochmal mit Aktiviertem mod_rewrite bis 21:00 so.

mfg
Thorsten
tutaeks
 
Posts: 11
Joined: 23. September 2004 19:29
Location: Essen

Postby sari42 » 14. February 2008 20:12

>Es kommt eine 403 meldung und man kommt nicht auf die Seite.

hier nicht, alles ok
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby tutaeks » 14. February 2008 20:51

Also um diese Zeit sollte die Seite nicht Funktioniert haben.

Probiere es jetzt bitte noch mal.

Aber dann wärst du der einzige bei dem sie laufen würde....


mfg
Thorsten
tutaeks
 
Posts: 11
Joined: 23. September 2004 19:29
Location: Essen

Postby sari42 » 14. February 2008 21:02

Forbidden

You don't have permission to access / on this server.

(vorhin ging's aber, waren so 10..12 pics... und register...
mein Besuch sollte im Apache log zu sehen sein,browser:seamonkey)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby tutaeks » 14. February 2008 21:12

Ja in den Logfiles steht es.

Oder sollte ich es zwischen durch noch mal umgestellt haben?
Meine eigentlich nicht.....hmmm

Und mein Post das ich die Seite wieder auf mod_rewrite umstelle war vorher.

Aber jetzt bekommste ja auch eine 403.


Das ist der zustand auf den ich um ca.19:25 umgestellt habe.

mfg
Thorsten
tutaeks
 
Posts: 11
Joined: 23. September 2004 19:29
Location: Essen


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests