PHP-URL mit abschließendem Slash wird nicht geparst

Alles, was den Apache betrifft, kann hier besprochen werden.

PHP-URL mit abschließendem Slash wird nicht geparst

Postby jaspu » 26. January 2008 14:58

Hallo,

ich habe gerade ein komisches Phänomen bei mir bemerkt:
Wenn ich statt "localhost/test.php" die URL mit einem Slash am Ende aufrufe ("localhost/test.php/"), dann wird der PHP-Code nicht geparst sondern wie in einer Textdatei angezeigt - woran kann das liegen?

Danke Euch
jaspu
 
Posts: 2
Joined: 26. January 2008 14:52

Postby sari42 » 26. January 2008 22:46

Auf die Idee muß man erst mal kommen ...

$_SERVER - Ausschnitt:
Code: Select all
[QUERY_STRING] =>
[REQUEST_URI] => /08test/0801jwCSS-NOglobal-reset.php/
[SCRIPT_NAME] => /08test/0801jwCSS-NOglobal-reset.php
ruft unter xampp(lite) 1.6.5 trotzdem die Seite auf.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby jaspu » 27. January 2008 08:19

Hallo Sari,

Danke erstmal für deine Mühe, aber leider kann ich mit der Antwort nicht so recht was anfangen: Was muss ich jetzt machen?
jaspu
 
Posts: 2
Joined: 26. January 2008 14:52

Postby Scory » 27. January 2008 12:23

Bei mir (unter Windows) ist das nicht so, da wird dennoch die Datei ausgeführt. Was ich personlich eigentlich schon fast als falsch empfinde - denn der Slash ist ein Sonderzeichen und signalisiert, dass das genannte Script keine normale Datei ist, sondern ein Ordner.

Warum aber dann der Text des Scripts ausgegeben wird (statt ein 404er Fehler - den würde ich verstehen!), das weiß ich nicht. Das ist in der Tat eine wüste Sicherheitslücke - die aber vielleicht auch durch eine (mir noch nicht bekannte) Fehlkonfiguration ausgelöst wird.

Gib doch mal ein paar präzise Infos über Version und Betriebssystem usw.

MfG
Scory
Scory
 


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests