.htaccess fordert bei Linkbetätigung ständig Zugangsdaten

Alles, was den Apache betrifft, kann hier besprochen werden.

.htaccess fordert bei Linkbetätigung ständig Zugangsdaten

Postby pedro2211 » 05. January 2008 12:09

Hallo,

zu .htaccess gibt es eine Menge Stoff im Internet, aber zu meinem
Problem habe ich leider nichts gefunden, daher wende ich mich
an euch. Vieleicht kann mir ja hier jemand weiterhelfen.

Ich habe einen dedizierten Server mit Apache2.
Nun habe ich einen Ordner mit ./htaccess geschützt, damit nur
Leute mit richtigen Zugangsdaten an den Inhalt dieses Ordners
herankommen. Funktioniert soweit auch prima, nur das ich jetzt jedesmal
wenn ich per Webseitenlink auf eine andere html-Datei in demselben Ordner
zugreifen will, meine Zugangsdaten eingeben muss. So war das
eigentlich aber nicht geplannt. Eigentlich wollte ich bei dem ersten
Zugriff auf den Ordner nach Zugangsdaten fragen, und dann nicht mehr,
bis der Browser neu gestartet wird.

Bin für jeden Denkanstoss dankbar....

Bis dahin ...

Pedro
pedro2211
 
Posts: 3
Joined: 05. January 2008 11:55

Postby Wiedmann » 05. January 2008 12:47

Funktioniert soweit auch prima, nur das ich jetzt jedesmal
wenn ich per Webseitenlink auf eine andere html-Datei in demselben Ordner
zugreifen will, meine Zugangsdaten eingeben muss.

- Genaue URI der Seite die den Link enthält?
- Genaue URI des Links auf den du klickst (a href im html)?
- Genaue URI der Seite die durch den Link geladen wird?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby pedro2211 » 05. January 2008 13:30

Hallo,

danke erst mal für das Interesse an meinem Problem.
Ich versuche das ganze noch mal zu beschreiben.

Ich habe einen Ordner "member" (.htaccess geschützt).

in diesem Ordner befinden sich
Dateien wie
index.php, member1.html, member2.html usw.

Wenn ich jetzt in den Browser
http://www.meine-domain.de/member/index.php
tippe, geht das Zugangsdaten-Fenster auf.

Ich gebe meine Zugangsdaten an, und werde erfolgreich auf
index.php
weitergeleitet.

(Soweit alles toll)

Nun habe ich in der geöffneten index.php einen Link untergebracht:
<a href="member1.html">Besuche member1 Seite im selben Ordner</a>

jetzt das Problem:
anstatt daß die Seite member1.html aufgeht,
geht schon wieder das Zugangsdaten-Fenster auf, obwohl ich die
Zugangsdaten doch gerade erst eingegeben hatte.

Vielen Dank für die Mühe im Voraus ....

Pedro
pedro2211
 
Posts: 3
Joined: 05. January 2008 11:55

Postby Wiedmann » 05. January 2008 17:51

und werde erfolgreich auf index.php weitergeleitet.

Welche URI steht nach der Umleitung in der Adresszeile deines Browsers?

anstatt daß die Seite member1.html aufgeht,
geht schon wieder das Zugangsdaten-Fenster auf, obwohl ich die
Zugangsdaten doch gerade erst eingegeben hatte.

Nach Eingabe der Zugangsdaten, welche URI wird im Browser angezeigt?


BTW:
Wenn ich jetzt in den Browser
http://www.meine-domain.de/member/index.php
tippe, geht das Zugangsdaten-Fenster auf.

Mit http://localhost/member/index.php würde alles funktionieren?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby pedro2211 » 06. January 2008 14:27

Hallo,

jetzt habe ich die Überlegungen in die falsche Richtung gelenkt.

Was ich nicht erwähnt hatte, das es sich bei der .htaccess Datei
um eine dynamisch durch ein Antibackdoor Script angelegte Datei handelt.

Das erschien mir nicht relevant, was sich als Fehler herausstellte.

Das Problem war nicht die .htaccess Datei oder die httpd.conf, sondern
ein falsch konfiguriertes Antibackdoor Script.

Danke noch mal für deine Mühe ....

Bis dahin ...

Pedro
pedro2211
 
Posts: 3
Joined: 05. January 2008 11:55


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests