vhost

Alles, was den Apache betrifft, kann hier besprochen werden.

vhost

Postby tobiasr » 13. December 2007 20:46

Hi ich habe ein Problem mit meinem vHost.
Ich bin mir um die Entwicklung leicter zu machen einige vHosts am einrichten.
Die windows hosts Datei habe ich entsprechend geändert.
Hier der Vhost Code.

<VirtualHost *:80>
ServerName localhost
ServerAdmin *********
DocumentRoot D:/xampp/htdocs
</VirtualHost>

<VirtualHost *:80>
ServerName banner24
ServerAdmin ************
DocumentRoot D:/xampp/htdocs/nedem/b24
</VirtualHost>

<VirtualHost *:80>
ServerName admin
ServerAdmin **********
DocumentRoot D:/xampp/htdocs/nedem/b24/71AD55MI33N
</VirtualHost>

Nun geht nur der Erste vHost die Anderen werden nicht berücksicht.
Wird auch beim Starten von Apache Ausgegeben.
Apache habe ich natürlich auf noch neu gestartet.
Nun wo ist der Fehler?
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby Scory » 14. December 2007 14:04

Das ist kein gültiger VirtualHost Block. Wenn Du das sog. "Namebased" VHOST benutzt, mußt Du erst den Namensraum definieren. Dort kannst Du am einfachsten per Wildcard alle Namen zulassen:

Code: Select all
NameVirtualHost *:80


Die Zeile fehlt bei Dir und deswegen werden die virtuellen Hosts nicht erkannt. Komplett muss es also so aussehen:

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
ServerAdmin *********
DocumentRoot D:/xampp/htdocs
</VirtualHost>

<VirtualHost *:80>
ServerName banner24
ServerAdmin ************
DocumentRoot D:/xampp/htdocs/nedem/b24
</VirtualHost>

<VirtualHost *:80>
ServerName admin
ServerAdmin **********
DocumentRoot D:/xampp/htdocs/nedem/b24/71AD55MI33N
</VirtualHost>


Dann mußt Du noch Apache neu starten.

Grüße
Scory
Scory
 

Postby tobiasr » 15. December 2007 06:49

Danke werde ich gleich Testen und melde mich dann noch mal.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby tobiasr » 15. December 2007 11:36

Nein geht immer noch nicht.
Hat einer noch eine Idee?

Edit:
Banner24 und Localhost gehen jetz,
aber admin geht nicht.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby Scory » 15. December 2007 16:28

Wie wäre es damit, mal in diversen Logfiles zu schauen (das ist der Sinn von Logfiles), vielleicht meldet Apache ja, warum es nicht klappt. D.h., er meldet es sogar ganz sicher, Du mußt es nur finden.
Scory
 

Postby tobiasr » 15. December 2007 17:11

Oh ja darauf bin ich nicht gekommen.
Ich schau mal nach und melde mich dann!

Habe was gemerkt:
Ich erzwinge SSL Verschlüsselung im Verzeichnis auf das "admin" geleitet wird.
Nun kommt auch die SSL Zertifikation, doch er leitet auf das Startverzeichnis um.
Wenn ich die SSL Verschlüsselungserzwingung pber modRewrite ausschalte geht es.
In wie fern hat das mit der Erzwinung durch modRewrite zu tun?
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Vhost auf Win Server 2003

Postby Cuba2006 » 18. December 2007 01:04

Hallo zusammen,
bin kurz vor einem Weinkrampf, hab mir bei Google, Apachefriends & Co schon einen Wolf gesucht, komme aber auf keinen grünen Zweig. Es wurde ein normaler XAMPP Web Server auf eine Win Server2003 Kiste installiert. Es funktioniert auch alles Wunderbar, SOLANGE man keine virtuellen Hosts verwendet. Verwende ich wie unten aufgeführt vhost, dann kann ich machen was ich auch will, ich werde IMMER in das defualt Verzeichnis, in diesem Fall localhost, geroutet. Wenn ich den Server mit apache -S starte bekomme ich folgende Meldung,
-------------------------------------------------------------------------------------
D:\Programme\xampp\apache\bin>apache -S
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
_default_:443 localhost (D:/Programme/xampp/apache/conf/extra/httpd-ssl.conf:74)
*:80 is a NameVirtualHost
default server localhost (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:28)
port 80 namevhost localhost (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:28)
port 80 namevhost www.eco-systemix.com (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:42)
port 80 namevhost www.air-albatros.de (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:56)
port 80 namevhost abrechnung.no-ip.biz (D:/Programme/xampp/apache/conf/extra/httpd-vhosts.conf:70)
Syntax OK

D:\Programme\xampp\apache\bin>
-------------------------------------------------------------------------------------
Das error.log schaut so aus:

[Tue Dec 18 00:51:52 2007] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4 configured -- resuming normal operations
[Tue Dec 18 00:51:52 2007] [notice] Server built: Sep 21 2007 00:29:38
[Tue Dec 18 00:51:52 2007] [notice] Parent: Created child process 2208
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Child process is running
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Acquired the start mutex.
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Starting 250 worker threads.
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Starting thread to listen on port 443.
[Tue Dec 18 00:51:54 2007] [notice] Child 2208: Starting thread to listen on port 80.
-------------------------------------------------------------------------------------
und das ist die httpd-vhosts.conf

#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80

<VirtualHost *:80>
ServerName localhost
ServerAdmin meine@mailadresse.de
DocumentRoot "D:/Programme/xampp/htdocs"
<Directory "D:/Programme/xampp/htdocs">
Options IncludesNoExec
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.eco-systemix.com
ServerAdmin webmaster@eco-systemix.com
DocumentRoot "/Programme/xampp/htdocs/EcoSys"
<Directory "D:/Programme/xampp/htdocs/EcoSys/">
Options Indexes +FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName www.air-albatros.de
ServerAdmin webmaster@air-albatros.de
DocumentRoot "/Programme/xampp/htdocs/Albatros"
<Directory "D:/Programme/xampp/htdocs/Albatros/">
Options Indexes +FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName abrechnung.no-ip.biz
ServerAdmin meine@abrechnung.no-ip.biz
DocumentRoot "/Programme/xampp/htdocs/xampp"
<Directory "D:/Programme/xampp/htdocs/PilotsPortal/">
Options IncludesNoExec
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
-------------------------------------------------------------------------------------
In der hosts Datei steht folgendes

127.0.0.1 abrechnung.no-ip.biz
127.0.0.1 air-albatros.de
127.0.0.1 eco-systemix.com
127.0.0.1 localhost
-------------------------------------------------------------------------------------
in der httpd.conf ist das include zuvhost unkommentiert.


Seht ihr auf die schnelle einen Fehler?

Bin für jeden Tipp dankbar.

Grüße,
Maik.
Cuba2006
 
Posts: 4
Joined: 17. December 2007 23:36

hat sich erledigt

Postby Cuba2006 » 18. December 2007 14:12

Liegt wohl irgendwie an 1und 1. Ich mache dafür einen neuen Thread auf.
Cheers,
Maik.
Cuba2006
 
Posts: 4
Joined: 17. December 2007 23:36


Return to Apache

Who is online

Users browsing this forum: No registered users and 1 guest