mod_rewrite für xampp

Alles, was den Apache betrifft, kann hier besprochen werden.

mod_rewrite für xampp

Postby Jipii » 19. November 2007 17:40

Guten Abend,

es gibt bereits ein Thread mit nahezu selbem Titel in dem Wole geholfen wird, allerdings ist bei mir die Situation etwas anders, eigentlich viel einfacher.
Ich habe auf Vista ganz normal Xampp (basic) 1.6.4 installiert, läuft auch alles wunderbar, allerdings mod_rewrite.

Jetzt habe ich stundenlang gegoogelt und folgendes erledigt:
- in apache/conf/httpd.conf "LoadModule rewrite_module modules/mod_rewrite.so" eingetragen (einkommentiert)
- auch dort habe ich die Angabe AllowOverride auf All gesetzt

Und das ist meine htaccess:
Code: Select all
RewriteEngine on
RewriteRule ^/datei\.html$ datei2.html [NC]


die htaccess findet er, denn wenn ich kacke reinschreibe gibt es nen 500er, aber bei aufruf der datei.html kommt 404.

Ich habe in diesem Forum sehr hilfreiche Beiträge gelesen, leider halfen die nichts, würde freuen wenn ihr mir da Ansätze gibt was ich zu tun habe um das zu korrigieren.
Danke im Voraus :wink:
Jipii
 
Posts: 2
Joined: 19. November 2007 17:30

Postby Wiedmann » 19. November 2007 17:49

Du musst den ersten Slash weglassen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Jipii » 19. November 2007 18:00

Stimmt, das ist es, geil danke :D

Die Formulierung habe ich von hier, sollte ich den Autor da drauf hinweisen oder meinte der eigentlich was anderes?
Jipii
 
Posts: 2
Joined: 19. November 2007 17:30


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests