problem mit vhost

Alles, was den Apache betrifft, kann hier besprochen werden.

problem mit vhost

Postby r4z0rbl4d3 » 26. October 2007 13:14

guten tag,

ich hab folgendes problem:

ich habe einen server mit 2 domains. ich habe mit der suchfunktion einige hilfe themen gefunden. allerdings funktioniert es nicht richtig. ich habe es so versucht:

Code: Select all

 NameVirtualHost 10.1.1.130:80

<VirtualHost 10.1.1.130:80>
ServerName www.xxx.de
DocumentRoot /www/
</VirtualHost>

<VirtualHost 10.1.1.130:80>
ServerName www.yyy.de
DocumentRoot /www/yyy
</VirtualHost>


es wird aber leider immer nur der erste eintrag benutzt. ich bin für jede hilfe überaus dankbar!
r4z0rbl4d3
 
Posts: 1
Joined: 26. October 2007 11:58

Postby Metzgermeister » 29. October 2007 15:31

Juhu ich bin nicht alleine ich habe das selbe Problem ich nutze Debain 4.0 R1 mit Apache2.

Ich habe schon soviel mit den Configs rumgespielt und komme nicht weiter es wird immer nur der erste Eintrag in den Config-Files zum Inhalte Laden verwendet. Mein Server soll bald 3 Domains verwalten da er aber noch im Konfigurationsstadium ist und bei mir daheim per dyndns erreichbar ist sind es im Moment 4 Domains da die dyndns-Domain ja auch angesprochen werden soll.

bei einer abfrage mit "httpd -S" in der Console bekomme ich folgende ausgabe alles was in Prozentzeichen steht habe ich ersetzt:
Code: Select all
default server %localdomain% (/etc/apache2/sites-enabled/000-default:2)
port * namevhost %domain1% (/etc/apache2/sites-enabled/001-vhosts.ini:27)
...
port * namevhost %dyndnsdomain% (/etc/apache2/sites-enabled/002-vhosts.ini:11)
port * namevhost %dyndnssubdomain% (/etc/apache2/sites-enabled/002-vhosts.ini:22)
...


da in der 000-default keine Pfad oder sonstigen Angaben drin stehen nimmt der Server die Konfiguration der ersten vhosts-Datei und dort den ersten Eintrag der auf Verzeichnisse verweist. Ansonsten lädt er nichts nach.

Was kann ich tun um dem endlich mal manieren beibringen zu können.
Metzgermeister
 
Posts: 1
Joined: 29. October 2007 15:07


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests