Kein Zugriff auf Documentroot in NTFS unter Linux

Alles, was den Apache betrifft, kann hier besprochen werden.

Kein Zugriff auf Documentroot in NTFS unter Linux

Postby chricken » 25. October 2007 06:21

Hallo,

ich bin schon seit einiger Zeit bei einem Problem, vielleicht kann mir hier ja wer helfen.
Ich habe ein Ubuntu 7.10 installiert, dazu Apache2 (und SQL und PHP)
Das läuft auch alles.
Nun habe ich auch ein Windows, das leider immer noch produktiv sein muss. Und ich habe eine NTFS-Partition, auf der mein Documentroot liegt. Das soll auch dort liegen bleiben, denn das ist mein Raid, auf das ich von beiden OS zugreifen können will.

Sinnigerweise will ich nun im Apache unter Linux dieses Verzeichnis als Documentroot einrichten.
Dazu habe ich in der Datei
/etc/apache2/sites-available/default
die Zeilen
DocumentRoot xyz und
<Directory xyz>
editiert und aktiviert

Dann dem Ordner die Rechte vergeben per
sudo chown -R root:www-data ./DocumentRoot
sudo chmod -R 775 ./DocumentRoot


und schließlich Apache neu gestartet
Bei einem Aufruf von localhost bekam ich dann ein
403 forbidden

Nach kurzem Prüfen der Rechte musste ich feststellen, daß der Besitzer des DocumentRoot immer noch "Plugdev" ist.
Auf Anraten bei einer anderen Frage änderte ich dann in der /etc/fstab die diese Partition betreffende Zeile in

UUID=88F0106EF01064AA /media/sda1 ntfs defaults,umask=002,gid=46 0 1

Das brachte leider auch nichts

Nun frage ich einfach mal:
Warum kann ich die Rechte nicht ändern? Das scheint ja daran zu liegen, daß die Rechte in NTFS nicht einfach so eingetragen werden können/dürfen. Ich dachte mit umask=002 wäre das Problem behoben, schade. Weiß vielleicht jemand eine andere Lösung?
Ein Link in das Homeverzeichnis funktioniert übrigens auch nicht.
Kann ich den Apache-Server vielleicht auch zu der Gruppe plugdev hinzufügen? Das dürfte das Problem beheben, aber ich weiß nicht, wie das geht, weil der Apache nicht als User auftaucht.

Vielen Dank
Chricken
chricken
 
Posts: 8
Joined: 25. October 2007 04:58

Postby chricken » 01. November 2007 07:25

So, hab's mit Hilfe gelöst.
Falls jemand dasselbe Problem hat:

Im Eintrag im fstab für die entsprechende Partition muss umask auf 000 stehen
Bei meinem Beispiel ist das:
UUID=88F0106EF01064AA /media/sda1 ntfs defaults,umask=000,gid=46 0 1

Weil NTFS ein gänzlich anderes Rechtesystem benutzt als ext muß man hier den Trick anwenden, daß einfach auf der gesamten Partition jeder alles darf. Dafür steht umask=000.
Jedenfalls habe ich es so verstanden und hier funktioniert das auch bestens *freufreufreu*
chricken
 
Posts: 8
Joined: 25. October 2007 04:58


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests