Apache webserver will nict starten ---- ABGESCHLOSSEN

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache webserver will nict starten ---- ABGESCHLOSSEN

Postby SubSonniC » 25. September 2007 18:47

Hallo Leute,

also ich hab grad nach anleitung den Apache webserver 2.2 installioert.

mit apr und apr-util

ganz normal ohne irgendwelche schnickschnacks.

beim starten bekomm ich folgende fehlermeldung

subsonnic@Cassiopeia:/opt/apache2.2.6/bin$ sudo ./apachectl -k start
(99)Cannot assign requested address: make_sock: could not bind to address 85.177.34.149:80
no listening sockets available, shutting down
Unable to open logs

in meine httpd.conf habe ich meine dyndns addy eingetragen und den port 80

mein ddclient läugt auch und dyndns.org mapped meine ip

wenn ich localhost:80 eintrage gehts auch.

ich sitze hier hinter einem router auf dem ich auch die portweiterleitung für port 80 eingetragen hab.

was stimmt den nicht.

es muss am router liegen, denn bevor ich ihn hatte lief auch ein apache wunderbar.

MFG

Subsonnic
Last edited by SubSonniC on 25. September 2007 21:56, edited 1 time in total.
Linux debian 4.0 etch
kernel 2.6.18 k7
d-link router
ddclient und dyndns.org
SubSonniC
 
Posts: 5
Joined: 25. September 2007 18:42

Postby Wiedmann » 25. September 2007 19:30

was stimmt den nicht.

Deine "Listen" und/oder "ServerName" Directive.
--> die lässt man so wie sie war.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby SubSonniC » 25. September 2007 20:31

ja dann geht zwar der server ohne probleme straten. aber über meine dyndns url bekomm ich dann "Server not found" meldung im Browser
Linux debian 4.0 etch
kernel 2.6.18 k7
d-link router
ddclient und dyndns.org
SubSonniC
 
Posts: 5
Joined: 25. September 2007 18:42

Postby Wiedmann » 25. September 2007 20:48

Leider weiss ja jetzt auch keiner, was du jetzt wirklich genau konfiguriert hast? Aussehen und konfiguriert sein müssen die Einträge so:
Code: Select all
Listen 80
ServerName localhost:80


Wenn es dann immer noch nicht geht, liegt es jedenfalls nciht am Apachen:
- Firewall im Rechner blockt
- Firewall im Router blockt
- port-forwarding im Router falsch eingestellt
- falsche IP bei DynDNS hinterlegt
- du rufst den DynDNS Namen aus dem lokalen Netz auf, und nicht aus dem Internet.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby SubSonniC » 25. September 2007 21:08

also die einstellungen sind korrekt.

probier doch mal ob DU als ausenstehender die index.html seite von apache aufrufen kannst.

subsonnic.dynalias.org

anpingen kann ich sie zumindest
Linux debian 4.0 etch
kernel 2.6.18 k7
d-link router
ddclient und dyndns.org
SubSonniC
 
Posts: 5
Joined: 25. September 2007 18:42

Postby Wiedmann » 25. September 2007 21:18

probier doch mal ob DU als ausenstehender die index.html seite von apache aufrufen kannst.

Beim test gerade jedenfalls nicht.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby SubSonniC » 25. September 2007 21:22

ok ich bin etwas weiter.

ich habe mal einfach meine unverschlüsselte ip in die browserzeile eingegeben und gugge da...

er hat "It Works" gefunden

jetzt muss ich doch noch mal nach dyndns schauen ob meine conf richtig ist .
Linux debian 4.0 etch
kernel 2.6.18 k7
d-link router
ddclient und dyndns.org
SubSonniC
 
Posts: 5
Joined: 25. September 2007 18:42

Postby SubSonniC » 25. September 2007 21:39

Problem gelöst

meine ddclient.conf war nicht richtig konfiguriert.

Danke für die Mühen.


MFG

Subsonnic
Linux debian 4.0 etch
kernel 2.6.18 k7
d-link router
ddclient und dyndns.org
SubSonniC
 
Posts: 5
Joined: 25. September 2007 18:42


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests