Apache hängt sporadisch

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache hängt sporadisch

Postby moon » 23. September 2007 15:28

Hallo Forengemeinde!

Habe folgendes Problem, dass (so vermute ich) vom Apache verursacht wird.
Die Webseite kann sporadisch nicht angezeigt werden. Da bei kommt aber auch nicht eine Fehlermeldung, dass die Seite nicht erreichbar wäre - sondern (ich verwende hauptsächlich den Firefox) der Browser ladet und ladet und ladet – ohne ende in sicht. Ich habe mal bereits 20 Minuten gewartet. Meistens lässt es ich umgehen, wenn ich z.B. einen anderen Link anklicke. Bei phpMyAdmin hilft dies aber auch nichts. Hier ist alles nicht erreichbar was im phpMyAdmin Verzeichnis liegt. In diesem Fall, muss ich Apache beenden bzw. neu starten.

Nachfolgend meine Daten:
OS: Windows XP Prof.
Apache Version: 2.2.4

Server Settings:
Server Version: Apache/2.2.4 (Win32) PHP/5.2.4
Server Built: Jan 9 2007 23:17:20
Module Magic Number: 20051115:4
Hostname/port: localhost:80
Timeouts: connection: 300 keep-alive: 300
MPM Name: WinNT
MPM Information: Max Daemons: 64 Threaded: yes Forked: no
Server Architecture: 32-bit
Server Root: C:/Server/Apache
Config File: C:/Server/Apache/conf/httpd.conf
Server Built With:
-D APACHE_MPM_DIR="server/mpm/winnt" -D APR_HAS_SENDFILE -D APR_HAS_MMAP -D APR_HAS_OTHER_CHILD -D AP_HAVE_RELIABLE_PIPED_LOGS -D HTTPD_ROOT="/apache" -D SUEXEC_BIN="/apache/bin/suexec" -D DEFAULT_ERRORLOG="logs/error.log" -D AP_TYPES_CONFIG_FILE="conf/mime.types" -D SERVER_CONFIG_FILE="conf/httpd.conf"

Current Configuration:
In file: C:/Server/Apache/conf/httpd.conf
Code: Select all
ThreadsPerChild 250
MaxRequestsPerChild  0

ServerRoot "C:/Server/Apache"

Listen 80

Include conf/extra/httpd-modulesdefault.conf

LoadModule php5_module C:/Server/PHP/php5apache2_2.dll
AddType application/x-httpd-php .php .html .htm

ServerAdmin admin@localhost

ServerName localhost:80

DocumentRoot "C:/Server/Files"

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Satisfy all
</Directory>

<Directory "C:/Server/Files">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<IfModule dir_module>
    DirectoryIndex index.html index.php
</IfModule>

<FilesMatch "^\.ht">
    Order allow,deny
    Deny from all
</FilesMatch>

ErrorLog logs/error.log
LogLevel warn

<IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>

    CustomLog logs/access.log common
</IfModule>

DefaultType text/plain

<IfModule mime_module>
    TypesConfig conf/mime.types

    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz
</IfModule>

<Location /server-info>
SetHandler server-info
</Location>


In file "conf/extra/httpd-modulesdefault.conf"
Code: Select all
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule asis_module modules/mod_asis.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
LoadModule imagemap_module modules/mod_imagemap.so
LoadModule include_module modules/mod_include.so
LoadModule info_module modules/mod_info.so
LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule userdir_module modules/mod_userdir.so


PHP habe ich bereits von Version 5.2.3 auf 5.2.4 aktualisiert.
Ich hoffe hier kann mir jemand helfen.

Grüße
Markus
(moon)
User avatar
moon
 
Posts: 2
Joined: 23. September 2007 15:13

Postby rc-hosting » 01. October 2007 12:12

Ich bin mir zwar nicht sicher aber es könnte an der Funktion keep-alive liegen da diese für eventuelle weitere Anfragen des Benutzers die Verbindung aufrecht erhält und gerade wenn man einige benutzer gleichzeitig drauf hat sind die Maximalen verbindungen schnell erreicht. Würde es einfach mal versuchen den Wert z.B. auf 30 zu ändern um zu sehen ob er dann wieder besser reagiert.

Hoffe das ist dein Problem? Wenn nicht kann ich sonst eigendlich auch keinen fehler in deinen Configs endecken.
ImageImageImage
rc-hosting
 
Posts: 16
Joined: 30. September 2007 22:27
Location: Billigheim-Ingenheim

Postby moon » 01. October 2007 18:39

Hallo!

Habe gestern auf die Apache Version 2.2.5 aktualisiert aber noch nicht wirklich getestet. Mal sehen ... 8)
Der Apache läuft isoliert nur auf diesem Rechner. D.h. nur ich habe darauf Zugriff. Apache wird hier nur als Test-Webserver für PHP eingesetzt.

Grüße
Markus
(moon)
User avatar
moon
 
Posts: 2
Joined: 23. September 2007 15:13


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests