PHP-Problem?

Alles, was den Apache betrifft, kann hier besprochen werden.

PHP-Problem?

Postby anme » 21. September 2007 21:34

Hallo!

Ich habe hier ein Problem, das mich verrückt macht. Ich habe mit einem Apache v1.3.27 und
PHP 4.3.1 drei IP-based virtual hosts aufgesetzt. Von außen sie diese drei hosts problemlos zu
erreichen. Von innen über meinen Squid erreiche ich nur einen dieser hosts, die anderen beiden
werden zum download angeboten: application/x-httpd-php

Hänge ich bei den beiden, die zum download angeboten werden, an den URL ein index.php an,
werden die Shops problemlos geöffnet. Das ist bei dem anderen nicht notwendig.

Die drei virtual hosts sehen in der Konfiguration gleich aus, bis auf die Servername natürlich usw.
Ich kann mir aus dieser Geschichte absolut keinen Reim machen. Es ist bei keinem der hosts ein
DirectoryIndex im Spiel (funktioniert auch nicht mit).

Kann da jemand was dazu sagen? Es scheint ein Netzwerkproblem mit PHP zu sein. Hänge ich den
Apache mit den virutellen hosts ins gleiche subnet, funktioniert alles wie es soll.

Was mit auch noch auffällt ist der schreckliche Output eines phpinfo. Das kenne ich von anderen PHP-Versionen
richtig schön in Farbe und so. Auch der phpinfo output funktioniert im gleichen subnet wurnderbar, nur nicht
in ein anderes subnet.

Grüße

Andreas
anme
 
Posts: 10
Joined: 21. September 2007 21:24

Postby Wiedmann » 21. September 2007 21:53

An die Möglichkeit das es am Squid liegt hast du gedacht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby anme » 22. September 2007 09:56

Wiedmann wrote:An die Möglichkeit das es am Squid liegt hast du gedacht?

Ja, auch. Mittlerweile glaube ich sogar, daß es eigentlich nur der Squid sein kann. Ich habe aber noch keine Lösung oder weis nicht, wo ich ansetzen soll.
Alle Verbindungen, die nicht über den Squid laufen, funktionieren ohne Probleme.

Andreas
anme
 
Posts: 10
Joined: 21. September 2007 21:24


Return to Apache

Who is online

Users browsing this forum: No registered users and 1 guest