Apache 2.2.6 ???

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache 2.2.6 ???

Postby kschroeder » 21. September 2007 14:37

Hallo,

mittlerweile wird ja überall schon die neueste Version vom Apache-Server 2.2.6 angepriesen.
Auf der Apache-Seite findet man leider nur keine aktuellen Binaries.
Weder für Linux noch für Windows.
Auf der Suche nach Binaries hab ich in einem Forum gelesen, dass die Windows-Version recht buggy wäre, zumindest 2 Module, unter anderem das mod_perl.
Hab auch irgendwo ne Version 2.2.5 entdeckt, von der ich vorher nie was gesehen hatte.

Da ich eigentlich recht dringend auf die neue Version vom Apache warte (insbesondere der neueren APR von Apache), wieso gibts noch keine Binary, wie sonst üblich?

Ist vielleicht bereits eine neue Version vom xampp in Arbeit?
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

Postby sari42 » 24. September 2007 12:27

http://www.apachelounge.com/download/ ->2.2.5 (2.2.6 wird dort nicht empfohlen)
REMOTE_ADDR auf w2k zeigt auch kein "0.0.0.0" mehr
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby kschroeder » 24. September 2007 13:05

Genau die Version hab ich ja auch gefunden.
Da diese Version aber sonst nirgends zu finden ist, bin ich ein wenig skeptisch, diese auch einzusetzen.

Mich wundert es nur, dass die 2.2.6 offiziell auf der Homepage von Apache zu freigegeben ist, aber eben keine Binaries, wie sonst üblich. Weder für Win32 noch für Linux.

Hier im Forum gibts auch bisher eigentlich keine Posts über 2.2.6. Sonst hagelt es schon Anfragen, wann die Version "endlich" im Xampp eingebaut ist...

Würd mich halt interessieren, ob jemand genaueres sagen kann.
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

Postby sari42 » 24. September 2007 19:04

bei mir läuft's prima :)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby kschroeder » 25. September 2007 08:31

Dann werd ich das wohl auch mal ins Auge fassen.
Hoffentlich funktionieren alle Module, die auch unter 2.2.4 gelaufen sind.
Insbesonde der SAP-Zugriff und die COM-Schnittstelle zu Lotus Notes müssen funktionieren.
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

Postby jb2k » 28. September 2007 09:53

In zwischen gibt es auf http://www.apachelounge.com/download/ 2.2.6 da die Leute dort die Version für Windows gepatched haben. In der apache dev Liste war zu lesen, das dieses patch in 2.2.7 einfließen soll.
jb2k
 
Posts: 2
Joined: 04. September 2006 12:49

Postby kschroeder » 28. September 2007 14:13

Klingt gut, werd ich probieren, sobald ich Zeit habe und ein Offline-Fenster für den Server zur Verfügung steht.
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

Postby sari42 » 28. September 2007 19:39

jb2k wrote:In zwischen gibt es auf http://www.apachelounge.com/download/ 2.2.6 da die Leute dort die Version für Windows gepatched haben. In der apache dev Liste war zu lesen, das dieses patch in 2.2.7 einfließen soll.
das ist nichts neues, denn dort steht:
Apache 2.2.5 is working great, well tested and stable as rock and 2.2.6 has over 2.2.5 very minor changes affecting windows. None of these changes affects us.
deshalb hab ich mich für 2.2.5 entschieden ;)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby kschroeder » 17. October 2007 09:55

Hab jetzt die gepatchte Version installiert und einige Tage laufen lassen.
Ich muss sagen, läuft einwandfrei, reibungslos und ohne Probleme.

Da ich dem Apache (denke ich) recht viel zumute, durch Zugriffe auf Notes über die COM-Schnittlstelle, durch RPC-Calls auf SAP etc..., kann ich das Update nur wärmstens empfehlen.

Das Update war auch simple: einfach Apache stoppen und die bestehenden Dateien (ausser den Config-Dateien httpd.conf etc.) überschreiben.
Apache wieder starten. Fertig.
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33

Postby sari42 » 17. October 2007 13:49

The XAMPP 1.6.4 is available!

We've released a new version of XAMPP, including:

* Apache HTTPD 2.2.6 + Openssl 0.9.8e
* MySQL 5.0.45
* PHP 5.2.4
* PHP 4.4.7
* phpMyAdmin 2.11.1
* Zend Optimizer 3.3.0
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby kschroeder » 17. October 2007 14:50

Hab ich auch gelesen, aber soweit ich gesehen habe, noch mit der "ungepatcheden" Version, also wo z.B. mod_perl nicht fehlerfrei läuft.
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33


Return to Apache

Who is online

Users browsing this forum: No registered users and 7 guests