Apache über VirtualPC ansprechen

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache über VirtualPC ansprechen

Postby KingJ » 21. September 2007 10:36

Hallo! Ich habe ein Problem, dem ich noch nicht so ganz herr werde. Folgende Ausgangssituation:

Mein PC läuft mit XP Pro. Habe darauf mit MS VirtualPC einen Suse Linux Apache Server installiert. Diesen (Suse) habe ich getestet. d.h. unter Linux heraus kann ich die Testseite auf dem System anzeigen.

Nun möchte ich aber in einem ersten Schritt auch von XP auf den im Virtual PC installierten Server zugreifen. Er zeigt mir aber an dass kein Server da ist. Sowohl wenn ich localhost eingebe, als auch wenn ich direkt die IP angebe.
In einem weiteren Schritt möchte ich natürlich auch über das Netz direkt auf meinen VirtualPC mit Suse/Apache zugreifen.

Kennt hier jemand eine Lösung für dieses Problem Wäre für jede Hilfe dankbar!
KingJ
 
Posts: 5
Joined: 21. September 2007 10:30

Postby glitzi85 » 21. September 2007 10:41

Hallo,

Er zeigt mir aber an dass kein Server da ist. Sowohl wenn ich localhost eingebe, als auch wenn ich direkt die IP angebe.

Welche IP? Mit localhost rufst du 127.0.0.1 auf der XP-Maschine auf. Dass du damit nicht in irgendeine Virtuelle Maschine kommst ist klar. Welche IP ist denn bei VirtualPC eingestellt?

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby KingJ » 21. September 2007 10:45

Hatte unter XP ipconfig eingegeben und hatte so die Nummer in meinem Netzwerk. Diese habe ich eingegeben und hatte keinen Zugriff. Die Virtual PC Konfiguration zeigt mir auch keine ander IP an.
KingJ
 
Posts: 5
Joined: 21. September 2007 10:30

Postby Wiedmann » 21. September 2007 10:53

Hatte unter XP ipconfig eingegeben

Du willst ja auf dein Linux zugreifen... Ergo musst du im Linux schauen was es für eine IP hat (ifconfig).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KingJ » 21. September 2007 10:59

Danke für die Antwort. Hab es versucht. er bricht ab wegen zeitüberschreitung. Habe auch versucht zu pingen geht auch nicht wegen dem selben problem?
KingJ
 
Posts: 5
Joined: 21. September 2007 10:30

Postby Wiedmann » 21. September 2007 11:13

Hab es versucht.

Was hast du versucht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Wiedmann » 21. September 2007 11:14

Hab es versucht.

Was hast du versucht?
Jedenfalls wohl nicht das, was ich geschrieben habe? Oder hast du jetzt eine korrekte IP?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KingJ » 21. September 2007 11:15

Habe unter Linux ifconfig ausgeführt und die entsprechende IP unter XP in den Browswer eingegeben und auch noch mal angepingt. Zeitüberschreitung
KingJ
 
Posts: 5
Joined: 21. September 2007 10:30

Postby Wiedmann » 21. September 2007 11:23

Habe unter Linux ifconfig ausgeführt und die entsprechende IP

Ist die IP auch aus dem gleichen Subnetz wie die von XP (netmask stimmt auch überein)?

In den Einstellungen des virtuellen PC's, ist da unter Netzwerk der Adapter 1 auch an deine physikalische Netzwerkkarte gebunden?

Wie sieht es mit dem Pingen von Linux zu XP aus (Stichwort Firewall)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby KingJ » 21. September 2007 11:31

Habe nun probiert: Von Linux nach xp (Ping) funktioniert nicht alles verloren.
Als Adapter ist unter Virtual PC NAT eingetragen.

Subnetz sagt mir noch nicht viel bin eher laie. Wenn du die Subnetzmaske meinst die ist mit 255.255.255.0 gleich. Firewalleinstellungen habe ich noch nicht prüfen können. Weiss unter Linux nicht wie das geht.
KingJ
 
Posts: 5
Joined: 21. September 2007 10:30

Postby Wiedmann » 21. September 2007 11:42

Als Adapter ist unter Virtual PC NAT eingetragen.

Dann ändere das mal wie gesagt auf die physikalische Netzwekkarte.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 9 guests