Apache RewriteRule ???

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache RewriteRule ???

Postby cotech » 17. September 2007 11:08

Hallo zusammen.

seit dem Wochenende sitze ich da dran rum und habe keine Lösung für mein Problem.

Ich habe folgende Situation:
1. Jboss AS Server http://locahost:8080/MyAPP/
2. Apache Web Server

Diese beiden Anwendungen sind auf einen Root Server installiert und laufen fur sich alleine ohne Probleme.

Jetzt will ich folgndes erreichen.

Alle anfragen, die über das WWW kommen sollen folgendermaßen aussehen:
http://meinRootserver.de/myapp
sollen dann weiter geleitet werden auf dem boss: http://locahost:8080/MyAPP/

Auf dem Root server ist nur Port 8080 freigeschaltet.

Meine Frage ist, wie kann ich das realisieren.

Mein System:
Debian 3.2
Apache2
Jboss AS 4

Danke und frendliche Grüße
cotech
 
Posts: 5
Joined: 17. September 2007 10:51

Postby Wiedmann » 17. September 2007 11:17

"http://meinRootserver.de/myapp"
Auf dem Root server ist nur Port 8080 freigeschaltet.

Mit dieser URI muss dein Server auch Port 80 erreichbar sein, und nicht nur über 8080.

"http://meinRootserver.de/myapp" sollen dann weiter geleitet werden auf dem boss: "http://locahost:8080/MyAPP/"

Das hört sich nach einem reverser Proxy an:
http://httpd.apache.org/docs/2.2/mod/mo ... assreverse
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Upps ein Fehler unterlaufen

Postby cotech » 17. September 2007 11:23

Hi,

Sorry mir ist da ein Tipfehler unterlaufen.

Dies sollte natürlich Port 80 sein.

Kann ich dann mit dem Proxy das so hinbekommen, dass immer feolgende URL angezeigt wird.
http://meinRootServer.de/myapp/......./....

Mir geht es auch darum, dass immer myapp da steht.
Wenn man den Proxy nutzt muss man dann irgendwelche Rewirte Rules die imzusammen hang mit dem context stehen entfernen???

Danke
cotech
 
Posts: 5
Joined: 17. September 2007 10:51

Klappt nicht ganz

Postby cotech » 17. September 2007 11:42

Hi zusammen,

habe jetzt folgendes verscht

Code: Select all
<IfModule mod_proxy.c>
        #turning ProxyRequests on and allowing proxying from all may allow
        #spammers to use your proxy to send email.

        ProxyRequests On
        <Proxy *>
                Order deny,allow
                #Deny from all
                Allow from all
        </Proxy>
        # Enable/disable the handling of HTTP/1.1 "Via:" headers.
        # ("Full" adds the server version; "Block" removes all outgoing Via: headers)
        # Set to one of: Off | On | Full | Block

        ProxyVia On
        ProxyPass /myapp/ http://127.0.0.1:8080/MyAPP-web/
        ProxyPassReverse /myapp/ http://127.0.0.1:8080/MyAPP-web/
</IfModule>



Jetzt bekomme ich die Fehlermeldung 403 Forbidden
You don't have permission to access /profiledatabase/ on this server.

Ich verstehe ich nicht wo jetzt das Problem sein sollte.

Ausserdem habe ich foglende Zeilen in den Log Dateien vom Apache gesehen:
Code: Select all
[Mon Sep 17 12:54:39 2007] [error] [client 212.89.xxx.xx] File does not exist: /htdocs
[Mon Sep 17 12:54:39 2007] [error] [client 212.89.xxx.xx] File does not exist: /htdocs
[Mon Sep 17 12:54:44 2007] [error] [client 212.89.xxx.xx] File does not exist: /htdocs
[Mon Sep 17 12:55:14 2007] [warn] proxy: No protocol handler was valid for the URL /myapp/. If you are using a DSO
version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.


Ich hoffe jemand hat da einen Rot.

Danke
cotech
 
Posts: 5
Joined: 17. September 2007 10:51

Postby Wiedmann » 17. September 2007 12:14

Code: Select all
ProxyRequests On

Beim Einsatz von ProxyPass/ProxyPassReverse sollte das "Off sein":
Code: Select all
ProxyRequests Off


You don't have permission to access /profiledatabase/ on this server.

Bei welcher Aktion kommt das genau? Aber wie es scheint, erzeugt deine WebApp HTML-Code mit absoluter Addressierung? HTML Code wird aber vom Apache reverse Proxy nicht umgeschrieben. Ergo funktioniert das nur, wenn im Code nur relative Adressen (URIs) vorkommen.

Alternativ gäbe es da noch das 3rd-party-Modul mod_proxy_html, was dann auch dies könnte.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cotech » 17. September 2007 12:20

Hi

habe den Fehler gefunden. Hier hatte jemand das selbe Problem und dank seinen Tip habe ich den Fehler für das Forbidden gefunden.

Mann muss das proxy_http mod einbinden.

Soll das jetzt heissen ich kann die Namen nicht ändern.
cotech
 
Posts: 5
Joined: 17. September 2007 10:51


Return to Apache

Who is online

Users browsing this forum: No registered users and 1 guest