Problem mit Datei-Upload

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem mit Datei-Upload

Postby Knight1 » 10. September 2007 17:42

Hi AF-Com,
habe da mal ein Problem.

Ich habe ein Script für einen Tennisverein geschrieben. Dieses läuft seit Anfang Januar optimal. Fehler in den Script waren bisher auf meinem mist gewachsen.
Dort haeb ich auch ein Konfigurations-Formular. In diesem Formular habe ich 30 Felder für Datei-Upload.
Nun bringt mir mein Apache einen Fehler in der error-Log-Datei mit dem ich nichts anfangen:
[Mon Sep 10 18:06:23 2007] [error] [client 192.168.0.3] ALERT - configured fileupload limit exceeded - file dropped (attacker '192.168.0.3', file '/srv/www/projekte/tennis/privat/update.php'), referer: http://tce.kkordel.dyndns.biz/privat/ed ... hat=config


Was mir die Meldung sagt ist, dass das Maximum an File-Uploads erreicht ist.
Ich kann aber in keiner Apache-Konfigurations-Datei eine Einstellung finden wo ich einen Wert ändern kann der sowas einstellt.

In PHP bekomme ich Fehlermeldungen auf die letzten 5 File-Upload-Felder dass die entsprechenden Indexe im Array $_FILES nicht vorhanden sind.

Hier mal einen Link zu den Screenshots zu den Installierten Apache und PHP Teile:
http://www.tc-eimsheim.de/screenshots/i ... _teile.jpg
http://www.tc-eimsheim.de/screenshots/i ... _teil1.jpg
http://www.tc-eimsheim.de/screenshots/i ... _teil2.jpg

Könnt Ihr mir bitte einen Tipp geben was ich einstellen muss um die Situation zu bereinigen.


Kai aka Knight1
Image
User avatar
Knight1
 
Posts: 310
Joined: 18. October 2003 10:03
Location: Trier
Operating System: Windows 7 Ultimate x64


Postby Knight1 » 12. September 2007 12:21



Hi lordal,
hat leider nicht geholfen. Habe den in Deinem zweiten Link angebenen Wert auf 100 geändert und Neustart gemacht. Leider ohne Erfolg. Alle anderen Werte sind hoch genug.


Kai aka Knight1
Image
User avatar
Knight1
 
Posts: 310
Joined: 18. October 2003 10:03
Location: Trier
Operating System: Windows 7 Ultimate x64

Postby Knight1 » 06. October 2007 17:13

Hi lordal,
Deine Antwort hat doch in gewisserweise geholfen.

Allerdings war es nicht der "suhosin.upload.max_upload"-Wert der zu ändern war. Es war der "suhosin.post.max_vars"-Wert der zu niedrig war.
Ich habe diesen Wert mal auf 200 hochgeschraubt, und entkommentiert.
Ich hatte bei meinem letzten Versuch die entsprechende Zeile nicht entkommentiert.

Jetzt geht's :D


Danke nochmal.



Kai aka Knight1
Image
User avatar
Knight1
 
Posts: 310
Joined: 18. October 2003 10:03
Location: Trier
Operating System: Windows 7 Ultimate x64


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests