Apache2 - Verzeichnisse schützen .htacces funktioniert nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

ohhhhhhhhh l e u t e

Postby networker-000 » 13. September 2007 13:28

ich habs doch selbst lösen können by "try and error" und siehe da... :D :D

alles zuvor war korrekt - nur in der /etc/apache2/sites-enabled/000-default

muss der Eintrag:
AllowOverride AuthConfig
lauten

Code: Select all
NameVirtualHost *
<VirtualHost *>
        ServerAdmin nix@test.de

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options FollowSymLinks MultiViews
                AllowOverride AuthConfig
                Order allow,deny
                allow from all
                # Uncomment this directive is you want to see apache2's
                # default start page (in /apache2-default) when you go to /
                #RedirectMatch ^/$ /apache2-default/
        </Directory>
networker-000
 
Posts: 9
Joined: 08. September 2007 23:27

Postby Wiedmann » 13. September 2007 13:36

alles zuvor war korrekt - nur in der /etc/apache2/sites-enabled/000-default

Oder anders gesagt:
Es wird doch nicht der VHost den du in "/etc/apache2/sites-available/pwtest" definiert hast benutzt.

Eigentlich auch logisch, da man jetzt ja sieht, dass du 2x den selben VHost definierst, und nur die 1. Definition zum Zuge kommen kann. Beim Start des Apache sollte das aber gemeldet werden. (Spätestens wenn man die Konfigdateien testen lässt)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Previous

Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests