<OS 10048) :make_sock: could not bind to address 0.0.0.0:

Alles, was den Apache betrifft, kann hier besprochen werden.

<OS 10048) :make_sock: could not bind to address 0.0.0.0:

Postby jahlmann » 03. September 2007 16:34

Apache konnte nicht gestarted werden. Fehlermeldung:
<OS 10048) :make_sock: could not bind to address 0.0.0.0:80

Wie kann ich wissen was socket 80 benutzt and wie kann ich 8080 benutzen?
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20

Postby ViperZero » 03. September 2007 16:58

In der Config-Datei gibt es einen Parameter "Listen"

Da wird bei dir im Moment

Listen 80

stehen. Einfach auf

Listen 8080

ändern.
Hoffe, gefolfen zu haben!
User avatar
ViperZero
 
Posts: 8
Joined: 30. August 2007 22:08
Location: Löhne / Ostwestfalen

Postby jahlmann » 03. September 2007 17:29

Hab's auf 8080 umgestellt. Jetzt bekomme ich den gleichen Fehler wieder, nur diesmal heißt es: cannot bind to address 0.0.0.0:443
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20

Postby ViperZero » 03. September 2007 17:44

Ok, das ist der SSL-Port, also für https:// Verbindungen.

Daher wird auf deinem Rechner schon irgendein anderer Webserver laufen und darum war auch eben die 80 schon belegt. Am besten suchst du in deinem System mal ein bisschen, wer dazwischen funken könnte.

Ansonsten in den Apache-Konfigs SSL abschalten.
User avatar
ViperZero
 
Posts: 8
Joined: 30. August 2007 22:08
Location: Löhne / Ostwestfalen

Postby jahlmann » 03. September 2007 17:48

OK, danke. Werde ich mal machen.

Gruß aus California
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20

Postby ManUnix » 03. September 2007 17:50

Hi jahlmann,

jahlmann wrote:Hab's auf 8080 umgestellt. Jetzt bekomme ich den gleichen Fehler wieder, nur diesmal heißt es: cannot bind to address 0.0.0.0:443

entweder läuft auf dem System, wie im vorherigen Post angesprochen schon ein Apache, oder Skype funkt dazwischen?

Skype kann als alternative Ports 80 und 443 belegen.

cu,
Manu
User avatar
ManUnix
 
Posts: 113
Joined: 16. April 2006 15:14

Postby jahlmann » 03. September 2007 18:18

Stimmt, skype läuft hier. :twisted:
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20

Weiteres Problem

Postby jahlmann » 04. September 2007 13:34

Mit den ports scheint es jetzt in Ornung zu sein, nachdem ich alles ausgestellt habe. Nun bekomme ich aber die Meldung: Apache 2 starting... aber passieren tut nichts.
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20

Postby ManUnix » 04. September 2007 14:32

Hi jahlmann,

irgendwelche Hinweise in apachestart.log und error_log?
User avatar
ManUnix
 
Posts: 113
Joined: 16. April 2006 15:14

Postby jahlmann » 04. September 2007 14:46

dies ist das Ende des erro.log:
[Tue Sep 04 05:39:12 2007] [notice] Child 3384: Exit event signaled. Child process is ending.
[Tue Sep 04 05:39:13 2007] [notice] Child 3384: Released the start mutex
[Tue Sep 04 05:39:14 2007] [notice] Child 3384: Waiting for 250 worker threads to exit.
[Tue Sep 04 05:39:14 2007] [notice] Child 3384: All worker threads have exited.
[Tue Sep 04 05:39:14 2007] [notice] Child 3384: Child process is exiting
[Tue Sep 04 05:39:14 2007] [notice] Parent: Child process exited successfully.
Error in my_thread_global_end(): 1 threads didn't exit :?: :?:
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20

Postby ManUnix » 04. September 2007 15:09

vielleicht hilft Dir dieser Thread weiter
User avatar
ManUnix
 
Posts: 113
Joined: 16. April 2006 15:14

Postby jahlmann » 04. September 2007 15:27

Hab's durchgelesen aber jetzt bin ich so schlau, oder dumm, wie vorher!
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20

Postby ManUnix » 04. September 2007 15:37

okay, kann ich ein paar Infos zum System haben? :)

Betriebssystem, XAMPP oder alleinstehender Apache, ...
User avatar
ManUnix
 
Posts: 113
Joined: 16. April 2006 15:14

Postby jahlmann » 04. September 2007 16:15

OK, kein Problem. Ich benutzte XAMPP
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20

Postby jahlmann » 04. September 2007 16:23

sorry: Windows XP professional
jahlmann
 
Posts: 9
Joined: 03. September 2007 16:20


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests