DocumentRoot auf Samba-Share

Alles, was den Apache betrifft, kann hier besprochen werden.

DocumentRoot auf Samba-Share

Postby ViperZero » 03. September 2007 14:56

Hallo,

ich habe bei mir Windows XP und hierdrin per VMWare ein Suse Linux 10.2 System laufen.
Nun möchte ich gerne einen Webserver mit PHP und MySQL auf der virtuellen Maschine, also unter Linux, aufsetzen. Da meine Daten allerdings ganz normal in einem Windows-Verzeichnis liegen, habe ich diese per Windows-Freigabe freigegeben. Unter Linux habe ich diese dann gemountet und als nächstes in meiner Konfig-Datei vom Apache dieses Verzeichnis als DocumentRoot angegeben.
Mein Problem hierbei ist folgendes: Wenn ich nun eine Anfrage an den Webserver sende, bekomme ich auch die Startseite (index.php) angezeigt, jedoch funktionieren sämtliche Referenzen auf andere Dateien (also auf das Stylesheet, die eingebundenen Bilder) nicht.
In den Server-Logs stehen allerdings die Anfragen für diese Dateien drin und dort steht auch der Status-Code 200.

Hat jemand von euch eine Ahnung, was da schief läuft und wie ich das abstellen kann?

Vielen Dank im Voraus schon einmal.
User avatar
ViperZero
 
Posts: 8
Joined: 30. August 2007 22:08
Location: Löhne / Ostwestfalen

Postby ViperZero » 05. September 2007 18:39

Für die Leute, die es interessiert. Ich habe aus einem anderen Forum folgende Lösung bekommen:

EnableSendfile Off
core - Apache HTTP Server
User avatar
ViperZero
 
Posts: 8
Joined: 30. August 2007 22:08
Location: Löhne / Ostwestfalen

Postby Iffets » 19. September 2007 20:52

genau das Problem hab ich auch!
Kann aber mit deiner Lösung nix anfangen - was meinst du denn damit?
Soll das in die httpd.conf rein?
Hab allerdings ein Windows2003-System ...

EDIT:

Hab jetzt einfach in die httpd.conf "EnableSendfile Off" reingeschrieben - hat sich aber gar nichts geändert ... :(
Welches Forum war denn das?
User avatar
Iffets
 
Posts: 8
Joined: 28. April 2005 11:14

Postby ViperZero » 20. September 2007 16:52

Dass muss in die httpd.conf rein, das ist schon richtig.
Und zwar muss das dort hin, wo du die Directory definierst.
Also:

<Directory: ???>
...
EnableSendfile Off
</Directory>


das war unter http://www.serversupportforum.de
User avatar
ViperZero
 
Posts: 8
Joined: 30. August 2007 22:08
Location: Löhne / Ostwestfalen


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests