Apache als ReverseProxy für Webserver: Forbidden (403)

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache als ReverseProxy für Webserver: Forbidden (403)

Postby laccolithgrunt » 23. August 2007 18:38

Hallo!
Ich möchte hinter meinen Apache nen anderen Webserver (Mongrel für Ruby on Rails) hängen. Der Webserver läuft auf dem Port 8000 und ist per http://serverip:8000 erreichbar. Ein http://serverip liefert jedoch ein Forbidden (403). Woran könnte das liegen?

/etc/apache2/httpd.conf:
<VirtualHost serverip:80>
ServerName serverip
ProxyPass / http://localhost:8000/
ProxyPassReverse / http://localhost:8000/
ProxyPreserveHost on
</VirtualHost>


/etc/apache2/mods-available/proxy.conf:
<IfModule mod_proxy.c>
ProxyRequests Off

<Proxy *>
AddDefaultCharset off
Order deny,allow
Allow from all
</Proxy>

ProxyVia On
</IfModule>
laccolithgrunt
 
Posts: 8
Joined: 06. April 2007 09:37

Postby cotech » 17. September 2007 11:58

Hi,

hast du schon eine Lösung bekommen.

Ich habe das selbe problem.

Danke
cotech
 
Posts: 5
Joined: 17. September 2007 10:51

Postby laccolithgrunt » 17. September 2007 12:05

Ja, bei mir läufts nun. Bei mir war ein Modul nicht geladen, ich glaube es war proxy_http. Bei mir sind folgende Module aktiv:
$ ls -1 /etc/apache2/mods-enabled/
alias.load
auth_basic.load
authn_file.load
authz_default.load
authz_groupfile.load
authz_host.load
authz_user.load
autoindex.load
cache.load
cgi.load
deflate.conf
deflate.load
dir.conf
dir.load
env.load
headers.load
mime.load
negotiation.load
php5.conf
php5.load
proxy_balancer.load
proxy.conf
proxy_http.load
proxy.load
rewrite.load
setenvif.load
status.load

Schau mal, ob bei dir auch alle Module von mir auftauchen...
laccolithgrunt
 
Posts: 8
Joined: 06. April 2007 09:37


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests