Apache 1.3 auf Win2k, Links im i-net funktionieren nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache 1.3 auf Win2k, Links im i-net funktionieren nicht

Postby denn76 » 27. September 2003 00:34

Hallo!

Habe hier ein mittelschweres Problem mit dem Apache 1.3. auf einem w2k Server. Die Webseiten im httpdoc Verzeichnis lassen sich im Intranet problemlos aufrufen, beim Aufruf via Internet funktioniert alledings nur die Indexseite.

Saemtliche Links versuchen ueber die interne Adresse (z.b. 192.168.2.2 etc. ) zu verbinden, was natuerlich nicht klappt.

Der Webserver steht hinter einer Firewall in einer Dmz, Portforwarding etc ist eingestellt und sollte eigentlich nicht das Problem sein. Ich vermute eher einen Fehler in der Apache Config...

Weiss nicht mehr weiter und bin fuer jede Hilfe aeusserst dankbar :)

Gruss

Dennis
denn76
 

Postby Antivirus » 27. September 2003 00:53

Das sieht nach einem Klassischen Homepagefehler aus

Alle deine Links sind z.B. http://192.162.0.1/news/september/1.html
anstatt /news/september/1.html

Im Intranet ist das ja kein Problem dein Rechner kennt die IP von deinem Server.

Aber im Internet kennen die andere User nur die Internet-IP (von deinem Provider) so haben sie keinen Zugriff

Die Lösung für dein Problem
alle Locale IP-Verknüpfungen löschen und universel aufbauen

Gruss Antivirus
User avatar
Antivirus
 
Posts: 124
Joined: 11. April 2003 19:33

Postby Kristian Marcroft » 27. September 2003 05:53

hi,

klassisches "Static Link -> Dynamic/Relativ Link" Problem...
Du musst den Sourcecode deiner Seiten überarbeiten.
Links nicht immer von http://192.168.0.1/hp/seite.html aus verlinken, sondern nur /hp/seite.html. und wenn du ein verzeichnis zurück willst ein .. davor also z.b. ../index.html

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby denn76 » 29. September 2003 10:37

ok, vielen dank das hat geklappt !


gruss

Dennis
denn76
 


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests