htaccess-Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

htaccess-Problem

Postby s01iD » 06. August 2007 23:22

Hi,
ich habe ein Problem mit einer htaccess-Datei.
Diese hat folgenden Inhalt:

Code: Select all
<FilesMatch "^index$">
  <  ForceType application/x-httpd-php >
</FilesMatch>


Habe bereits in der httpd.conf die AllowOverrides auf All und auch die Options auf All gesetzt. Kein Erfolg (trotz Neustart ;-)).
Der error.log schmeißt folgenden Fehler:
Code: Select all
[Tue Aug 07 00:14:35 2007] [alert] [client 127.0.0.1] C:/Programme/xampp/htdocs/homepagebaukasten/.htaccess: Expected </> but saw </FilesMatch>


Könnt ihr mir sagen, was ich aktivieren muss, damit das Skript funktioniert?
Auf meinem anderen Rechner mit selbst kompilierten Webserver funktioniert alles Bestens, daher schließe ich mal einen Fehler in der .htaccess-Datei aus.

Vielen Dank im Voraus :)
s01iD
 
Posts: 2
Joined: 06. August 2007 23:16

Postby Wiedmann » 06. August 2007 23:27

Code: Select all
<  ForceType application/x-httpd-php >

ForceType ist keine Block-Direktive, und wird somit nicht in "< ... >" eingeschlossen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby s01iD » 06. August 2007 23:31

Danke für den Hinweis. Funktioniert nun schon mal ohne Error 500.
Nun wird leider das "index" in der URL
Code: Select all
http://localhost/homepagebaukasten/index/page/unsere_objekte/

nicht als index.php interpretiert, sondern unbehandelt gelassen.

Hast Du dafür auch noch ein Workaround? ;)
Ziel ist es, ohne mod_rewrite, eine Suchmaschinenoptimierung zu realisieren ...
s01iD
 
Posts: 2
Joined: 06. August 2007 23:16

Postby Wiedmann » 06. August 2007 23:58

Nun wird leider das "index" in der URL
http://localhost/homepagebaukasten/inde ... e_objekte/
nicht als index.php interpretiert, sondern unbehandelt gelassen.

a) Woher soll der Apache auch wissen, dass das /index/ die Datei "index.php" sein soll.
(b) und dann Filterst du ja im FilesMatch Block auch auf die Datei "index" und nicht auf die Datei "index.php".)

Ziel ist es, ohne mod_rewrite, eine Suchmaschinenoptimierung zu realisieren ...

Dazu muss eigentlich nur "Options +MultiViews" für das Verzeichnis gesetzt sein.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests