Eigerne Seite Hochladen

Alles, was den Apache betrifft, kann hier besprochen werden.

Eigerne Seite Hochladen

Postby michi25 » 19. July 2007 14:08

Grüß euch!

Kann mir von euch vieleicht jemand sagen wie ich auf Ubuntu und Apache mir meine Eigerne Seite hochladen kann? Apache2 ist schon installiert und gestartet. Jedoch bin ich ein kompletter Noob was Linux und Apache angeht und die suche spuckt auch keine Themen aus die mir weiterhelfen, falls es das Thema schon mal gab was ich glaube wäre es nett wenn mir jemand denn link posten könnte!

Ich will eigendlich nur das mir auf Apache meine Seite angezeigt wird!

Danke für eure Hilfe! 8)
michi25
 
Posts: 9
Joined: 19. July 2007 14:01

Postby tobiasr » 19. July 2007 14:28

Was für ein Apach, xampp oder den Linkux Apache Server.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby michi25 » 19. July 2007 14:29

Linux Apache server, vielen dank
michi25
 
Posts: 9
Joined: 19. July 2007 14:01

Postby tobiasr » 19. July 2007 15:38

wenn du keine ahnung von Apache und Linux hast lade dir besser Xampp runter.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby michi25 » 19. July 2007 15:45

Naja ich mach gerade Ferialjob und soll das aber mit Unbuntu und Apache machen ist das leicht so schwierig das ich das nicht hinbekomme?

Im Prinzip müsste das doch ganz einfach gehn indem ich irgend wo in einer config datei denn richtigen pfad hineinschreibe oder?

Gibt es im Internet nicht vieleicht wo eine wenn möglich Deutsche anleitung wie das geht?

Vielen Dank schon mal!
michi25
 
Posts: 9
Joined: 19. July 2007 14:01

Postby tobiasr » 19. July 2007 16:03

schau mal in /var/user/www nach ob dort das Verzeichnis ist?!
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby michi25 » 20. July 2007 07:45

Danke da ist das Verzeichniss! :D

Jetzt muss ich nur mehr meine HTML datein da rein kopieren oder?
michi25
 
Posts: 9
Joined: 19. July 2007 14:01

Postby tobiasr » 20. July 2007 07:52

ja genau und dann gibst du in deinen Browser deine Netzwerk IP ein.
Das ist im normalfall 192.168.178.**.
Oder versuch es mit localhost.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby michi25 » 20. July 2007 08:52

Das problehm ist nur das er immer schreibt "Sie haben nicht die nötigen zugrifsrechte um in diesen Ordner zu schreiben"???

Was muss ich da tun?

Danke schon mal!
michi25
 
Posts: 9
Joined: 19. July 2007 14:01

Postby michi25 » 20. July 2007 09:37

So jetzt hab ichs geschaft jetzt ist der schreibschutz weg und hab meinen ordner mit meinen HTML files hineinkopiert. Das problem ist jetzt nur das er mir die nicht anzeigt!

Danke schon mal für eure hilfe!

edit: Ich bin da grad schwer überfordert, auf der Startseite steht da "Index" mit den Ordner Apache2-default aber mein Ordner steht da nicht dabei wie geht das?

Ich hab jetzt schon in der httpd.conf ServerRoot "/srv/www" dazugeschrieben für den Pfad jedoch klappt das nicht.

Pleas help!
michi25
 
Posts: 9
Joined: 19. July 2007 14:01

Postby tobiasr » 20. July 2007 10:50

wenn du nicht klar kommst hohle dir besser Xampp.
Mit Xampp ist es leichter.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby michi25 » 20. July 2007 10:54

Ja, wo bekomme ich das für ubuntu her?

Muss ich dann Apache deinstalieren?

Danke erstmal für deine Hilfe!

edit: Gibt es vieleicht irgendwo wenn möglich in deutsch eine schritt füt schritt anleitung?
michi25
 
Posts: 9
Joined: 19. July 2007 14:01

Postby tobiasr » 20. July 2007 11:31

eine Anleitung kenne ich nicht.
Den Apache musst du deinstallieren und dann Xampp für Linux Installieren.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Postby michi25 » 20. July 2007 11:37

Und ist es wirklich so schwierig einen Apache server einzurichten wenn man das noch nie gemacht hat?

Danke aufjedenfalls mal!

Ich habs jetzt so weit geschaft das ich im Index menü wenn ich auf defaul gehe meine seite hab doch ich hätte gerne anstatt des Index menüs meine Seite, jetzt kann ich nur noch einen kleinen schritt davon entfernt sein bis es klappt wäre für jeden tipp dankbar!
michi25
 
Posts: 9
Joined: 19. July 2007 14:01

Postby tobiasr » 20. July 2007 15:08

Wenn du ein Index Menü hast must du in eine .htaccess Datei
Options -Indexes
schreiben (dann kommt die Meldung "error 403), oder deine Seite index.html/.php nennen.
User avatar
tobiasr
 
Posts: 40
Joined: 14. July 2007 20:27

Next

Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests