Probleme beim Binding an interne IP

Alles, was den Apache betrifft, kann hier besprochen werden.

Probleme beim Binding an interne IP

Postby reikje » 18. July 2007 10:37

Hallo, ich habe vor ein paar Tagen zum ersten Mal Apache installiert. Die Version ist 2.2.4 Windows (Binary). Ich würde den Server gerne an eine interne IP binden. Die IP lautet 192.168.1.100 und ist via NAT auf eine externe IP Adresse gemapped. Dem Rechner sind noch 3 weitere interne IP Adressen zugeteilt, auf denen teilweise bereits andere Dienste auf Port 80 laufen (z.b. Tomcat auf 192.168.1.101:80).

Der Apache soll wie gesagt auf 192.168.1.100:80 laufen und sich via mod_jk mit einem Tomcat unterhalten der auf 192.168.1.100:8009 läuft. Das ganze funktioniert ohne IP Binding prima:
Listen 80
ServerName localhost:80

Wenn ich das hier angebe:
Listen 192.168.1.100:80
ServerName 192.168.1.100:80

werden keine Requests mehr angenommen. Was genau ist an dieser Einstellung falsch? Muss ich hier irgendwie mit <VirtualHost> arbeiten? Danke im Voraus
reikje
 
Posts: 2
Joined: 18. July 2007 10:22

Postby Wiedmann » 18. July 2007 10:58

Code: Select all
Listen 192.168.1.100:80
ServerName 192.168.1.100:80

Was genau ist an dieser Einstellung falsch?

Das Listen ist ok. Bei ServerName sollte ein Name und keine IP stehen (z.B. einfach "localhost:80").

werden keine Requests mehr angenommen.

Wie und mit was testest du das? Was spricht netstat?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby reikje » 18. July 2007 11:55

Das Listen ist ok. Bei ServerName sollte ein Name und keine IP stehen (z.B. einfach "localhost:80").


Das hat es leider auch nicht gebracht. Mit dieser Einstellung startet alles, aber ich komme dann nicht mehr über http://www.domainname.de rauf. Wenn ich intern auf der Kiste ein telnet 192.168.1.100 80 mache, kommt allerdings eine Antwort.

Mit der Einstellung:
Listen 80
ServerName localhost:80

lauscht antwortet der Apache auf alle IP Adressen die auf dem Server zur Verfügung stehen (192.168.1.101 - 104). Das ist in sofern verwunderlich, da unter 192.168.1.101:80 wie angesprochen bereits ein Tomcat standalone läuft. Netstat hab ich gemacht, kann mit der Ausgabe aber nicht besonders viel anfangen :(
reikje
 
Posts: 2
Joined: 18. July 2007 10:22

Postby Wiedmann » 18. July 2007 12:03

Mit dieser Einstellung startet alles, aber ich komme dann nicht mehr über http://www.domainname.de rauf. Wenn ich intern auf der Kiste ein telnet 192.168.1.100 80 mache, kommt allerdings eine Antwort.

Dann woird wohl im DNS-Server der Host "www.domainname.de" nicht auf die IP "192.168.1.100" zeigen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests