AWStats prerotate Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

AWStats prerotate Problem

Postby killerloop1977 » 27. June 2007 17:29

Hallo!

Habe auf einem Apache2 AWStats laufen. Die Logfiles werden erfolgreich stündlich analysiert.

/var/spool/cron/crontabs/root sieht so aus:
Code: Select all
@hourly /usr/share/doc/awstats/examples/awstats_updateall.pl now -awstatsprog=/usr/lib/cgi-bin/awstats.pl #AWStats


Das klappt wie gesagt so weit. Wenn ich aber das selbe Kommando als prerotate fürs logrotate definiere, werden die Statistiken nicht erzeugt. Genau sieht das folgender Maßen aus.

/etc/logrotate.d/apache2 sieht so aus:
Code: Select all
/var/log/apache2/*.log {
   missingok
   rotate 13
   compress
   delaycompress
   notifempty
   create 640 root adm
   sharedscripts
   postrotate
   if [ -f /var/run/apache2.pid ]; then
   /etc/init.d/apache2 restart > /dev/null
   fi
   endscript
   monthly
   olddir /var/log/apache2/archiv
   prerotate
   /usr/share/doc/awstats/examples/awstats_updateall.pl now -awstatsprog=/usr/lib/cgi-bin/awstats.pl
   endscript
}


Im Zuge der Logrotation wird zwar awstats_updateall.pl auch erfolgreich gestartet, und man sieht, das auch die einzelenen AWStats confs nach der Reihe irgendwie verarbeitet werden, aber die Statistiken werden nicht erneuert.

Der Output (den man bei manuell angestoßener logrotation über Webmin bekommt) sieht folgender Maßen aus:
Code: Select all
Running '"/usr/lib/cgi-bin/awstats.pl" -update -config=xyz -configdir="/etc/awstats"' to update config xyz
Content-type: text/html; charset=
Cache-Control: public
Last-Modified: Tue Jun 26 17:49:59 2007
Expires: Tue Jun 26 17:49:59 2007



Was ist falsch konfiguriert?

Danke
Killerloop
killerloop1977
 
Posts: 4
Joined: 25. June 2007 20:23

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests

cron