Web Formular unter 1.x ca. 50 mal schneller als unter 2.x ?

Alles, was den Apache betrifft, kann hier besprochen werden.

Web Formular unter 1.x ca. 50 mal schneller als unter 2.x ?

Postby MS Master » 17. September 2003 10:20

Hi all,

ich habe ein Formular für eine normale anfrage auf einer Page. Im Formular selber ist nichts ungewöhnliches drinnen, dafür gibt es ein ungewöhnliches Phänomen je nach Version des Apache :

Unter Apache 1.3.28 wird das Formular in 0,0xx Sekunden erzeugt und angezeigt.

Unter Apache 2.0.47 hingegen dauert es 4,xx sekunden bis sich was tut.

PHP ist beidesmal die gleiche Version 4.3.3 mit indem falle ja identischen einstellungen, da eben wie gesagt dieselbe Version, also gleiches Verzeichniss, gleiche PHP.ini etc. zum einsatz kommt.

Kann mir jemannd erklären, warum das mit der 2.xer Version so lange dauert, bzw. warum er dort eine "denkpause" einlegt :?:
User avatar
MS Master
 
Posts: 34
Joined: 27. May 2003 12:52

Postby nemesis » 17. September 2003 10:24

4 sec. kann definitiv nicht sein, als was läuft php unter den jeweiligen apache versionen, cgi, oder per mod_php?
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby MS Master » 17. September 2003 16:47

Hi,

zu den 4 Sekunden : Ist aber so.

Zu der integration : Läuft beides mal als Modul.

Ich vergass evt. hinzuzufügen das ich es unter Windows 2000 laufen habe.

Es ist auch egal welche PHP.ini ich benutze, also "php.ini-dist" oder "php.ini-recommended" als Basis.

Wie gesagt, unter Apache 1.3.28 popt das Formular sofort auf, während Apache 2.0.47 eine "pause" macht, und erst nach ca. 4 Sekunden das Formular zeigt.

Interessant ist evt. das ich 3 deklarationen für Array´s habe, für Anrede, Bundesland und Staat, wobei Staat alle ISO Staaten enthällt, also recht groß ist.

"Deaktiviere" ich diese Array´s, läuft auch unter 2.0.47 das Formular blitzschnell.

Dachte erst das es an einer "fehlerhaften" PHP.ini einstellung liegen würde, aber wie gesagt, die gleiche PHP Version mit dem Apache 1.3.28 gestartet führt das Formular in ca. 0,01 sekunden aus, also kann es nicht an den Array´s bzw. den ausgabe schleifen liegen.
User avatar
MS Master
 
Posts: 34
Joined: 27. May 2003 12:52

Postby nemesis » 17. September 2003 22:17

hm... der Fehler läßt sich also Reproduzieren, wenn du die Iso Liste mit einbindest... kannst mal nur den Aufruf und die liste als Zip-Archiv zum testen bereitstellen?
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby Guest » 18. September 2003 06:33

Hi,

klar :Hier

Wie gesagt, den "fehler" konnte ich auf mehreren Windows Maschinen mit Apache 2.0.47 nachvollziehen.

Und auf allen läuft es mit 1.3.28 blitzschnell.

Unter 2.0.47 läuft es auch schneller wenn ich das Array in Zeile 6 deaktiviere.
Guest
 

Postby nemesis » 18. September 2003 10:42

k, kleine Frage, wie ruft man das auf? Die Seite bleibt leer...
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby Guest » 18. September 2003 12:13

Ups, anleitung vergessen ;)

kontakt.php?action=list

Habs nochmal ein bissel getestet, jetzt tritt der fehler nur noch mit der "php.ini-recommended" auf, aber auch dort nur im apache 2.0.47.
Guest
 

Postby MS Master » 18. September 2003 12:14

Ups, jetzt habe ich auch noch als gast gepostet, aber egal, passt schon.
User avatar
MS Master
 
Posts: 34
Joined: 27. May 2003 12:52

Postby nemesis » 18. September 2003 22:43

k gut, dann lag ich doch nicht mal so falsch, konnte aus Zeitgründen das mit action nicht mehr testen :) habs nur mit ?list probiert. Naja schwamm drüber.
Wie zu erwarten war, funktioniert es einwandfrei... nur unter Apache 2.0.42 lief es etwas langsamer, aber mit 2.0.47 (PHP/4.3.3RC2-dev) einwandfrei!
Bist dir sicher das du nicht irgendwas an den mitgelieferten ini's geändert hast?
Bzw. läuft irgend ein Virenscanner der alle Datein im Hintergrund scannt bevor Apache/Php darauf zugreifen kann?

Zumindest McAfee 7.0 Virenscanner "bremste" den Apache so gut aus, das garnix geht :)

Allgemein ist Apache 2.0.47 unter Last schneller als 1.3.28, vielleicht etwas zuwenig Ram, oder der Cache der Festplatte wird durch was anderes zufällig in dem moment belegt? Zum testen einfach mal 3 Lieder anhören (bei 8mbyte cache).

Mehr fällt mir jetzt wirklich nicht mehr dazu ein, auch wenn das letzte eher dumm klingt, aber was solls :)
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby MS Master » 19. September 2003 06:45

Hi,

also nen P4 2,66 Ghz auf nem Asus P4G8X Deluxe mit 1 GB Corsair XMS 3200 Ram im Dualchannel betrieb sollte wohl nicht "zuwenig" Performance liefern.

Zumal, und ich wiederhole es zum x.ten male ich in beiden Apache Versionen DIESELBEN PHP.INI Dateien verwende.

PHP 4.3.3 ist NUR 1x Installiert, und ich starte nur Apache jeweils aus verschiedenen verzeichnissen.

Und wie gesagt, mit der "php.ini-recommended" wird das plötzlich sau lahm, mit der normalen geht es , aber mit der teste ich selten, da ich auf sicherheit aus bin.

Und lahm wird es eben auch nur unter 2.0.47, nicht aber mit 1.3.28 welcher das Script weiterhin in 0,0x sekunden ausführt, während 2.0.47 neuerdings je nachdem zwischen 5,x und 9,x sekunden braucht.

Virenscanner ist drauf, aber da der immer läuft, müsste es auch IMMER langsam sein, ist es aber nicht.

Nur Apache 2.0.47 mit "php.ini-recommended" ist langsam.

Alles anderen kombinationen laufen "schnell".

Da aber Apache 1.3.28 mit der "php.ini-recommended" sau schnell ist, kann es nicht nur eine PHP einstellung sein, sondern müsste wenn schon an beiden liegen, auser Apache 2.x hat mit einer der einstellungen probleme, dann währe es nur nett zu wissen mit welcher.
User avatar
MS Master
 
Posts: 34
Joined: 27. May 2003 12:52

Postby nemesis » 19. September 2003 11:02

so *böseguck*

; Whether to enable the ability to force arguments to be passed by reference
; at function call time. This method is deprecated and is likely to be
; unsupported in future versions of PHP/Zend. The encouraged method of
; specifying which arguments should be passed by reference is in the function
; declaration. You're encouraged to try and turn this option Off and make
; sure your scripts work properly with it in order to ensure they will work
; with future versions of the language (you will receive a warning each time
; you use this feature, and the argument will be passed by value instead of by
; reference).
allow_call_time_pass_reference = Off <-- so ists in der recommended ini

[client 127.0.0.1] PHP Notice: Undefined variable: style in D:\xampp\htdocs\table_allgemein.inc.php on line 3
[client 127.0.0.1] PHP Notice: Undefined variable: style in D:\xampp\htdocs\table_allgemein.inc.php on line 4
[client 127.0.0.1] PHP Notice: Undefined variable: style in D:\xampp\htdocs\table_allgemein.inc.php on line 5

usw. auch in der kontakt.php hatte 100% CPU Auslastung, und wenn du etwas mehr aufgepasst hättest, würdest die Fehler auch in der phperror.log finden!
Ubuntu 8.04 | SMP P3 1.4 GHz | 6 GByte RegECC | 74 GByte Seagate 15k5 system | 3Ware 9550SXU-4LP with 4x 500 GByte Seagate ES2 Raid 10 data | StoreCase DE400 | PX-230A | Intel Pro/1000MT Dual PCI-X
User avatar
nemesis
AF Moderator
 
Posts: 999
Joined: 29. December 2002 13:14
Location: Ingolstadt

Postby MS Master » 19. September 2003 17:40

Hi,

der fehler ist ja logisch, weil du gar nicht alle Style daten hast, die habe ich weggelassen.

Ein auskomentieren von Zeil 97 hätte das problem mit den fehlenden Style daten recht einfach gelöst.

Habe den fehler aber auch so schon gefunden und bereits behoben, jetzt läuft das auch in 0,0x sekunden mit der "sicheren" PHP.ini
User avatar
MS Master
 
Posts: 34
Joined: 27. May 2003 12:52


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests