Apache2 & WebDAV Schreibrechte

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache2 & WebDAV Schreibrechte

Postby Loom » 13. May 2007 13:43

Hallo, ich hoffe ich trage mein anliegen im richtigen forenbereich vor, ansonsten seht es mir bitte nach, bin neu hier Wink

also ich als blutiger debian neuling habe heute das webDAV modul für apache installiert. soweit funktioniert es auch super d.h ich kann auf meinen server zugreifen bzw. mein freigegebenes verzeichnis mit osx 10.4 mounten.

allerdings kann ich leider keine dateien von meinem mac auf das gemountete laufwerk kopieren, dazu fehlen mir anscheinend die nötigen schreibrechte! ein weiteres problem ist, das ich auf der debian maschine mit meinem "normalen nutzer" nichts in das webDAV Verzeichnis kopieren kann, was natürlich auch irgendwie doof ist^^

wenn mir bitte jemand helfen könnte diese zwei probleme in den grriff zu bekommen, wäre ich sehr sehr dankbar!

wie gesagt ich bin absoluter neuling und bin mit allem noch nicht richtig vertraut. ich bin jetzt auch schon ca. 1 stunde am googlen aber finde leider nichts was mir die lösung meines problems näher bringt!

anbei noch meine /etc/appache2/sites-enabled/homepage.homelinux.org konfig (wenn sie das wirklich ist^^)

Zitat:
<VirtualHost *>
ServerAdmin xxx@xx.de
ServerName homepage.homelinux.org
ServerAlias http://homepage.homelinux.org

DocumentRoot /home/srw/homepage.homelinux.org
<Directory /home/srw/homepage.homelinux.org>
Options Indexes MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>


# Note Alias goes to our DocumentRoot.
Alias /webdav /home/srw/homepage.homelinux.org

# But we apply different settings
<Location /webdav>
DAV On
AuthType Digest
AuthName "webdav-homepage"
AuthUserFile /home/srw/digest-password
Require valid-user
</Location>

</VirtualHost>


p.s. nach diesem howto habe ich den server installiert http://www.debian-administration.org/articles/285
Loom
 
Posts: 1
Joined: 13. May 2007 13:41

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests