Problem mit der Ausführung eines Servlets

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem mit der Ausführung eines Servlets

Postby d.ausstroit » 22. March 2007 09:16

Hai. Ich bin an einem Punkt angekommen, wo ich Eure Hilfe brauche. Ich habe XAMPP mit dem Tomcat-Addon auf meinem Entwicklungsrechner installiert. Als Anwendung habe ich ein Applet entwickelt, welches über ein Servlet auf eine DB zugreifen soll. Ich habe alles in das Verzeichnis /webapps vom Tomcat kopiert und kann lokal darauf zugreifen (http://localhost:8080/AppServTest/). Das haut hin. Des weiteren kann ich auch über http://localhost den Apachen ansprechen. Das heißt der Apache lauscht an 80 und der Tomcat an 8080. Nun möchte ich die Anwendung über das www mit www.xxx.homedns.org ansprechen. An den Apachen komme ich dran aber der Tomcat ist nicht zu erreichen. Ich versuche es über www.xxx.homedns.org:8080/. Aber das geht nicht :evil:

Was mach ich nur falsch?

Dirk
d.ausstroit
 
Posts: 11
Joined: 23. November 2006 15:24

Postby d.ausstroit » 22. March 2007 14:54

Ich habe noch ein bisschen rumprobiert :(. Dabei habe ich festgestellt, dass auch das Beispiel vom Tomcat lokal funktioniert. Ich habe hierzu unter dem Verzeichnis "webapps" ein Unterverz. erstellt. Hierein habe ich die zugehörigen Dateien kopiert. Allerdings findet er es über das www mit www.xxx.homesdns.org nicht.

Muss ich in irgendeiner xml-Datei noch was ergänzen? Ich was bald nicht mehr weiter :(
d.ausstroit
 
Posts: 11
Joined: 23. November 2006 15:24

Postby d.ausstroit » 23. March 2007 09:48

Kann mir denn keiner Helfen? Schluchz :x
d.ausstroit
 
Posts: 11
Joined: 23. November 2006 15:24


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests