Prob nach Umstieg XAMPP 1.4 zu 1.6 / vHosts ohne hosts-Datei

Alles, was den Apache betrifft, kann hier besprochen werden.

Prob nach Umstieg XAMPP 1.4 zu 1.6 / vHosts ohne hosts-Datei

Postby Jelllo » 05. March 2007 20:40

Hallo,

nach dem Umstieg von XAMPP 1.4.13x zu 1.6.0a werden die vHosts nicht mehr dargestellt - lediglich 127.0.0.1.

hier die Einträge in der httpd.conf :

Code: Select all
NameVirtualHost *:80


<VirtualHost *:80>
    ServerName localhost:80
    DocumentRoot  "D:/apachefriends/xampp/htdocs"
    <Directory    "D:/apachefriends/xampp/htdocs">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>



<VirtualHost 127.0.0.2:80>
    ServerName www.beispiel.de:80
    DocumentRoot  "D:/webs/www.beispiel.de/"
    <Directory    "D:/webs/www.beispiel.de/">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>


Diese Vorgehensweise hatte für mich bisher den Vorteil, dass ich neue vHosts ausschliesslich in der httpd.conf ergänzen musste und nichts in der hosts-Datei.

Ging bisher schön einfach, da ich immer weiter durchnummerieren konnte, also 127.0.0.2, 127.0.0.3, 127.0.0.4 usw.

Durch die Umstellung auf die aktuelle XAMPP-version hat sich nun offensichtlich etwas geändert.

Für einen konkreten Hinweis mit der richtigen Code-Zeile wie ich speziell den 2.Abschnitt mit 127.0.0.2 ändern muss, bin ich sehr dankbar, da ich offensichtlich nicht den Wald vor lauter Bäumen sehe.

Vielen Dank
Last edited by Jelllo on 05. March 2007 22:59, edited 1 time in total.
Jelllo
 
Posts: 5
Joined: 05. March 2007 20:29

Postby Wiedmann » 05. March 2007 20:50

Ging bisher schön einfach, da ich immer weiter durchnummerieren konnte, also 127.0.0.2, 127.0.0.3, 127.0.0.4 usw.

Andere (automatische) IP's als 127.0.0.1 im Bereich 127.x.x.x müssen vom OS unterstützt werden (und sind nciht wie manche meinen "von Gott gegeben" *g*)

Du kannst auch verschiedene VHosts auf einer IP benutzen, die sich am Port unterschieden. dann musst du die "hosts" auch nicht ändern.

Oder, wenn du sowas öfters hast, kannst du auch mod_vhost_alias benutzen, und weiterhin nur die "hosts" ändern, anstatt die "httpd.conf".

BTW:
Wenn man eh wie du eigentlich IP basierende VHosts hat / haben will, dann ist dort die Directive "NameVirtualHost" unnötig.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Jelllo » 05. March 2007 21:00

Hallo Wiedmann,

vielen Dank für Deine schnelle Antwort!

Wiedmann wrote:

Du kannst auch verschiedene VHosts auf einer IP benutzen, die sich am Port unterschieden. dann musst du die "hosts" auch nicht ändern.


Wenn ich Dich richtig verstanden habe, dann meinst du so:


Code: Select all
# NameVirtualHost *:80


<VirtualHost *:80>
    ServerName localhost:80
    DocumentRoot  "D:/apachefriends/xampp/htdocs"
    <Directory    "D:/apachefriends/xampp/htdocs">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>



<VirtualHost localhost:81>
    ServerName localhost:81
    DocumentRoot  "D:/webs/www.beispiel.de/"
    <Directory    "D:/webs/www.beispiel.de/">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>


In der hosts steht nur:
127.0.0.1 localhost


Bei Aufruf im Browser von http://localhost:81 kriege ich Ladefehler.
http://localhost:80 wird richtig angezeigt.

Was muss ich noch korrigieren.
Jelllo
 
Posts: 5
Joined: 05. March 2007 20:29

Postby Wiedmann » 05. March 2007 21:30

Was muss ich noch korrigieren.

k.d.a. ...

- Benutzt nur du dieser Server lokal?
- Was ist ein Ladefehler?
- steht was im "error.log"?
- wie startest du den Apachen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Jelllo » 05. March 2007 22:06

Wiedmann wrote:- Benutzt nur du dieser Server lokal?

ja

Wiedmann wrote:- Was ist ein Ladefehler?

Seiten-Ladefehler -> Fehler: Verbindung fehlgeschlagen

Wiedmann wrote:- steht was im "error.log"?

Code: Select all
[Mon Mar 05 22:02:19 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon Mar 05 22:02:19 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Mon Mar 05 22:02:19 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon Mar 05 22:02:19 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Mon Mar 05 22:02:20 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.1 configured -- resuming normal operations
[Mon Mar 05 22:02:20 2007] [notice] Server built: Jan 30 2007 12:11:56
[Mon Mar 05 22:02:20 2007] [notice] Parent: Created child process 2644
[Mon Mar 05 22:02:21 2007] [notice] Child 2644: Child process is running
[Mon Mar 05 22:02:21 2007] [notice] Child 2644: Acquired the start mutex.
[Mon Mar 05 22:02:21 2007] [notice] Child 2644: Starting 250 worker threads.
[Mon Mar 05 22:02:21 2007] [notice] Child 2644: Starting thread to listen on port 443.
[Mon Mar 05 22:02:21 2007] [notice] Child 2644: Starting thread to listen on port 80.


Wiedmann wrote:- wie startest du den Apachen?

per control-panel
Jelllo
 
Posts: 5
Joined: 05. March 2007 20:29

Postby Wiedmann » 05. March 2007 22:15

- Benutzt nur du dieser Server lokal?

ja

Dann sollten die VHosts so definiert werden:
Code: Select all
<VirtualHost 127.0.0.1:80>
...
Listen 8080
<VirtualHost 127.0.0.1:8080>
...
Listen 8081
<VirtualHost 127.0.0.1:8081>
...
usw.


BTW: unterhalb 1024 solltest du keine eignen Ports belegen.

Seiten-Ladefehler -> Fehler: Verbindung fehlgeschlagen

Dürfte am fehlen "Listen" liegen. (bei localhost ist in der FW ja normal alles frei)

- wie startest du den Apachen?

per control-panel

Damit was ich zwar jetzt mit was, aber nicht wie: Service- oder Applicationmodus.

Dürfte hier zwar weniger wichtig sein, aber manchmal sieht man beim Start mit z.B. der Batchdatei noch Hinweise in der Konsole.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Jelllo » 05. March 2007 22:36

Wiedmann wrote:- wie startest du den Apachen?

per control-panel,
also application
wenn ich den portcheck starte, ist alles frei.


meinst du so:

Code: Select all
# NameVirtualHost *:80

<VirtualHost 127.0.0.1:80>
 ServerName 127.0.0.1:80
    DocumentRoot  "D:/apachefriends/xampp/htdocs"
    <Directory    "D:/apachefriends/xampp/htdocs">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
Listen 80
</VirtualHost>

<VirtualHost 127.0.0.1:8081>
    ServerName 127.0.0.1:8081
    DocumentRoot  "D:/webs/www.beispiel.de/"
    <Directory    "D:/webs/www.beispiel.de/">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
Listen 8081
</VirtualHost>

<VirtualHost 127.0.0.1:8082>
    ServerName 127.0.0.1:8082
    DocumentRoot  "D:/webs/www.beispiel2.de/"
    <Directory    "D:/webs/www.beispiel2.de/">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
Listen 8082
</VirtualHost>


hmm, damit startet der apache nicht mehr ?!
Jelllo
 
Posts: 5
Joined: 05. March 2007 20:29

Postby Wiedmann » 05. March 2007 22:45

per control-panel,
also application

Nein. Das CP kann den Apachen als Service oder als Application starten.

wenn ich den portcheck starte, ist alles frei.

Dann läuft in diesem Augenblick der Apache nicht.

meinst du so:

Nein:
- Beim 1. VHost hatte ich kein "Listen" (da schon in der Hauptkonfig definiert)
- Die weiteren "Listen"-Direktiven stehen auserhalb des VHost-Blockes.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Jelllo » 05. March 2007 22:57

Klasse, das war's :)

Für Interessierte bzw. denen das gleiche widerfährt, hier nun die richtigen Einträge in der httpd.conf:

Code: Select all
# NameVirtualHost *:80

<VirtualHost 127.0.0.1:80>
 ServerName 127.0.0.1:80
    DocumentRoot  "D:/apachefriends/xampp/htdocs"
    <Directory    "D:/apachefriends/xampp/htdocs">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>

Listen 8081
<VirtualHost 127.0.0.1:8081>
    ServerName 127.0.0.1:8081
    DocumentRoot  "D:/webs/www.beispiel.de/"
    <Directory    "D:/webs/www.beispiel.de/">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>

Listen 8082
<VirtualHost 127.0.0.1:8082>
    ServerName 127.0.0.1:8082
    DocumentRoot  "D:/webs/www.beispiel2.de/"
    <Directory    "D:/webs/www.beispiel2.de/">
        Order Allow,Deny
        Allow from all
        #Options All
        #AllowOverride All
    </Directory>
</VirtualHost>


Wiedmann, ich danke Dir für Deine Mühen und Deine Geduld :!:
Jelllo
 
Posts: 5
Joined: 05. March 2007 20:29


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests