Vhost Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

Vhost Problem

Postby McPhee » 17. February 2007 19:47

Hi Zusammen

Ich habe zich Threads hier durchgelesen und sämtliche varianten durch die vhost-conf anzupassen, entweder startet mein apache dann nicht mehr oder ich landet trotz 3 verschiedener domains immer im gleichen Ordner.

Vielleicht erklärt sich hier jemand bereit mir helfen zu wollen , ich verzweifel seit 2Tagen restlos.

Ich möchte 2 Domains auf dem Server adden

1. Domain : domain1.ath.cx im Ordner C:\Program Files\xampp\htdocs\seite1

2.Domain: domain2.ath.cx im Ordner C:\Program Files\xampp\htdocs\seite2

Ich habe mehrere confs hier im forum gelesen und alles durch probiert, jedesmal wenn ich seite 1 aufrufe landet ich richtig, wenn ich aber seite 2 aufrufe lande ich im gleichen verzeichnis , an dem pfad kanns nicht liegen der war schon richtig.

Hoffe mir kann wer helfen.

Edit: bitte verschieben, bin beim posten wohl im forum falsch gerutscht.
McPhee
 
Posts: 1
Joined: 17. February 2007 17:32

Postby dyingPhoenix » 21. February 2007 12:00

Leider kann ich dir nicht wirklich helfen. Kannst du deine Konfigurationsdatei posten?

Ich poste dir mal meine Konfiguration. Ich bin auch lange an vhosts verzweifelt ;-)

Viel Erfolg.

Code: Select all
NameVirtualHost 10.70.0.89:80
<VirtualHost 10.70.0.89:80>
        ServerName web.mueller-intern.de
        ServerAlias web
        Documentroot /opt/lampp/htdocs
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory "/opt/lampp/htdocs">
                Options Indexes FollowSymLinks ExecCGI Includes
                AllowOverride All
                Order allow,deny
                Allow from all
        </Directory>
        <Directory "/opt/lampp/cgi-bin">
                AllowOverride None
                Options None
                Order allow,deny
                Allow from all
        </Directory>
</VirtualHost>
<VirtualHost 10.70.0.89:80>
        ServerName dc.mueller-intern.de
        ServerAlias dc
        Documentroot /daten/www
        ScriptAlias /cgi-bin/ "/daten/www/cgi-bin/"
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>

</VirtualHost>

dyingPhoenix
 
Posts: 19
Joined: 21. December 2004 14:43

Postby glitzi85 » 21. February 2007 16:18

Hallo,

in der httpd.conf sollte irgendwo Listen xxx stehen, relativ weit oben. Dort sollte Listen 80 drin stehen. Wenn da dahinter eine IP steht, am besten auf Listen 80 ändern.

Dann sollte ziemlich weit unten der Befehl Include conf/extra/httpd-vhosts.conf stehen. Falls davor ein # steht, dieses entfernen.

Dann die vHosts. Diese werden normalerweise im Unterordner extra in der Datei httpd-vhosts.conf gespeichert. Diese mal öffnen.

Dort entweder alles löschen oder vor jede Zeile ein # setzen, sofern nicht schon eins dasteht.

Dann diesen Code hier einsetzen:

Code: Select all

<Directory "C:/Program Files/xampp/htdocs">
    Options FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

<VirtualHost *:80>
    DocumentRoot "C:/Program Files/xampp/htdocs/seite1"
    ServerName domain1.ath.cx
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:/Program Files/xampp/htdocs/seite2"
    domain2.ath.cx
</VirtualHost>


Den Directory-Block kannst du weglassen, wenn das htdocs das Standard-htdocs von der XAMPP-Installation ist. Jetzt den Apachen neu starten und dann sollte es eigentlich funktionieren.

Wenn nicht, musst du eventuell noch einen VirtualHost-Block für den ServerNamen erstellen (in der httpd.conf unter ServerName schauen - Kannst du auch nur lokal freigeben (<VirtualHost 127.0.0.1:80>).

Wenn du das nächste mal XAMPP neu installierst, am besten NICHT in Ordner mit Leerzeichen installieren. Das macht oft Probleme, daher ist der Standardpfad auch C:/apachefriends.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests