Problem mit mod_rewrite

Alles, was den Apache betrifft, kann hier besprochen werden.

Problem mit mod_rewrite

Postby Maniac_81 » 15. February 2007 16:22

Moin,

hab folgendes Problem:

Apache läuft auf Debian Sarge 2.1
mod_rewrite modul wird durch die Config geladen, ist also richtig verlinkt.
laut phpinfo() isses geladen.
Wenn ich aber nun per .htaccess dynamische Links durch statische ersetzen will kommt folgende fehlermeldung: 403 - Forbidden!

Die error.log spuckt dazu folgendes aus:

Code: Select all
Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/web6/html/wbb2/


wo liegt hier der fehler. kenne mich da leider zu wenig damit aus. die httpd.conf ist auch fast leer, also wird die config über was anderes geladen, aber ich wüsste jetzt nicht wo.
Maniac_81
 
Posts: 6
Joined: 15. February 2007 09:32

Postby Wiedmann » 15. February 2007 16:59

wo liegt hier der fehler.

Steht doch in der Fehlermeldung?
--> Weder FollowSymLinks noch SymLinksIfOwnerMatch ist aktiviert.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Maniac_81 » 16. February 2007 06:44

kannst du mir bitte noch sagen wo ich die aktiviere? wäre nett, danke :)
Maniac_81
 
Posts: 6
Joined: 15. February 2007 09:32

Postby Wiedmann » 16. February 2007 09:15

Die Options-Directive wird in der "httpd.conf" konfiguriert.

Siehe auch:
http://httpd.apache.org/docs/2.2/mod/core.html#options
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Maniac_81 » 16. February 2007 18:24

also ich hab diesen eintrag in der confixx_vhost.vonf gefunden:

<Directory "/var/www">
<Files ~ "^\.ht">
deny from all
</Files>
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Options None
Options +FollowSymLinks +Includes
</Directory>


was muss ich da ändern? hab da jetzt schon "AllowOveride On"
und "Options On" versucht aber lappt nicht.
Maniac_81
 
Posts: 6
Joined: 15. February 2007 09:32

Postby Wiedmann » 16. February 2007 18:44

Code: Select all
Options +FollowSymLinks +Includes

was muss ich da ändern?

Nichts. So wie es da steht müsste es tun.

Entweder wird diese Einstellung an andere Stelle wieder überschrieben, oder diese Konfigdatei wird nicht benutzt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Maniac_81 » 17. February 2007 11:39

ich hab jetzt in der vhost einstellungen des benutzers einfach

Options -FollowSymLinks -Includes

in

Options +FollowSymLinks +Includes

geändert, nun scheint es zu funktionieren.
Maniac_81
 
Posts: 6
Joined: 15. February 2007 09:32


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests