Index of

Alles, was den Apache betrifft, kann hier besprochen werden.

Index of

Postby nico07 » 14. February 2007 13:01

Hi @ all,

ich habe mit Apache, Mysql, php und phpmyadmin eine webserver erstellt. Mein problem ist jetzt, dass wenn ich z.b.: http://localhost/info.php eingebe, der browser mir die datei anzeigt, aber wenn ich nur http://localhost/ eintippe listet er mir nicht die datei (info.php) auf, sondern er zeigt mir nur diese seite , wo steht ( Es klappt! Der Apache-Webserver ist auf dieser Website installiert!).

Meine frage ist jetzt, wie kann ich das so einstellen, dass er mir immer die dateien vom server auflistet (index of), wenn ich http://localhost eintippe.

THX im voraus

nico07
nico07
 
Posts: 8
Joined: 13. February 2007 22:43

Postby Wiedmann » 14. February 2007 15:19

dass er mir immer die dateien vom server auflistet (index of)

Das macht er immer dann, wenn es kein Document mit dem Namen "index.*" in diesem Verzeichnis gibt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby nico07 » 14. February 2007 15:27

Aso, aber wie soll ich das jetzt machen ? Im Ordner Apache\htdocs befinden sich viele dateien mit dem namen index. (index.html.en ,index.html.sv,index.html.var, usw.) Ich habe als test mal alle index dateien rauskopiert, aber trotzdem zeigt er immer noch (Es klappt! Der Apache-Webserver ist auf dieser Website installiert! ) an.

Was soll ich machen ??
nico07
 
Posts: 8
Joined: 13. February 2007 22:43

Postby Wiedmann » 14. February 2007 15:40

aber trotzdem zeigt er immer noch (Es klappt! Der Apache-Webserver ist auf dieser Website installiert! ) an.

Entweder das macht der Cache von deinem Browser, oder du hast eine übersehen.

Mach doch mal das ganze Verzeichnis leer. Von dem was der Apache mitliefert, braucht du dort gar nichts.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby nico07 » 14. February 2007 16:25

Wenn ich das mache, sagt er mir

Forbidden

You don't have permission to access / on this server.

wenn ich http://localhost eingebe.
nico07
 
Posts: 8
Joined: 13. February 2007 22:43

Postby Wiedmann » 14. February 2007 16:39

Sehr schön. Und jetzt lesen wir im Apache-Manual nach, wie man mod_autoindex für ein Verzeichnis (hier das DOCUMENT_ROOT) aktiviert...
http://httpd.apache.org/docs/2.2/mod/mod_autoindex.html wrote:Automatic index generation is enabled with using Options +Indexes. See the Options directive for more details.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby nico07 » 14. February 2007 17:33

Hab im manual nachgeschaut und alles ausprobiert, kriege es aber einfach nicht hin. Kannst du mir vielleicht sagen, wo ich genau in der httpd.conf das einstellen muss?

THX im voraus
nico07
 
Posts: 8
Joined: 13. February 2007 22:43

Postby Wiedmann » 14. February 2007 18:03

Irgendwo wie es einen "<Directory>" Block für dein DocumentRoot. Und in diesem Block musst du "Options" - Directive entsprechend erweitern (s.o.).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby nico07 » 14. February 2007 20:53

JUHUU endlich funktioniert es. Danke nochmal für deine Hilfe.

Gruß
nico07
 
Posts: 8
Joined: 13. February 2007 22:43


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests