httpd.conf Fehler

Alles, was den Apache betrifft, kann hier besprochen werden.

httpd.conf Fehler

Postby ahi » 30. January 2007 14:32

Hallo,
wenn ich meinen Apache neustarten möchte klappt das nicht.
In der Action log steht
--------------------------------------------------------------------------
Di 30 Jan 2007 12:55:31 CET
Operation restart with the VPS(s) VEID5171
service "apache2" is started. Fertig

Di 30 Jan 2007 12:55:31 CET
Syntax error on line 9 of /etc/apache2/httpd.conf: Fertig

Di 30 Jan 2007 12:55:31 CET
Invalid command 'Alias', perhaps mis-spelled or
defined by a module not included in the server configuration Fertig

Di 30 Jan 2007 12:55:31 CET
Operation restart with the VPS(s) VEID5171
service "apache2" is finished with errors: #703
Can not start/stop/restart service: Syntax error on line 9 of /etc/apache2/httpd.conf: Invalid command 'Alias',
perhaps mis-spelled or defined by a module
not included in the server configuration . Fehlgeschlagen
----------------------------------------------


die hhtpd.con sieht so aus

------------------------------------------------
##configuration here, consider
# adding it in your own file (/etc/apache2/httpd.conf.local)
# putting its name into APACHE_CONF_INCLUDE_FILES in
# /etc/sysconfig/apache2 -- this will make system updates
# easier :)


## CONFIXX
Alias /myadmin /srv/www/htdocs/myadmin
<Location /myadmin/>
php_admin_value open_basedir /srv/www/confixx/tmp/:/srv/www/htdocs/myadmin
</Location>

Include /etc/apache2/confixx_mhost.conf



# It is imperative that this entry remain at the end of the file

## /CONFIXX
--------------------------------------------

Kenne mich leider nicht aus,
kann mir jemand sagen, was da falsch ist?

vielen Dank schon mal
Grüße
Ahi
ahi
 
Posts: 13
Joined: 23. November 2006 12:46

Postby Wiedmann » 30. January 2007 14:47

kann mir jemand sagen, was da falsch ist?

Eigentlich sagt er es dir ja ;-)

Invalid command 'Alias', perhaps mis-spelled or
defined by a module not included in the server configuration

Er sagt dir hier das er "Alias" nicht kennt. Entwegen falsch geschrieben, oder es fehlt das Modul welches "Alias" erst bereitstellt.

Da wir jetzt einfach mal Wissen, dass es "Alias" grundsätzlich gibt und es auch so heschrieben wird, muss also das dazugehörige Modul fehlen.


Schauen wir mal ins Apache-Manual...
http://httpd.apache.org/docs/2.2/mod/mo ... html#alias

Aha :idea: "Alias" wird über das Modul "mod_alias" bereitgestellt.

Ergo:
Du musst über LoadModule dieses Modul noch laden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ahi » 30. January 2007 15:00

wird das so gemacht?

LoadModule alias_module

kommt das auch in die httpd.conf?
ahi
 
Posts: 13
Joined: 23. November 2006 12:46

Postby Wiedmann » 30. January 2007 15:29

LoadModule alias_module

Vom Prinzip ja. (aber s.u.)

kommt das auch in die httpd.conf?

Da oder in eine andere Konfigdatei... (s.u.)

Schau doch einfach mal nach, wo und wie bei dir die anderen Module geladen werden.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ahi » 30. January 2007 17:37

Hi,
sorry für die späte Rückmeldung.
Ich habe keine conf gefunden, wo irgendwelche Module geladen werden.
Es steht überall nur if Modul...usw
Wenn ich LoadModule alias_module in die httpd.conf eintrage, bringt die action log Syntaxfehler.
Wie sollte den die Syntax genau aussehen?
Habe gesucht aber irgendwie nichts konkretes gefunden.
Ich habe gestern an den Dateien httpd.conf, confixx_vhost.conf und confixx_mhost.conf folgendes eingefügt und wieder gelöscht.
Seither habe ich dieses Problem.

<Directory /srv/www/htdocs/web1/html/>
Options Indexes +FollowSymlinks
</Directory>

<Directory /srv/www/htdocs/web1/html/>
Options Indexes ++SymLinksIfOwnerMatch
</Directory>
ahi
 
Posts: 13
Joined: 23. November 2006 12:46

Postby Wiedmann » 30. January 2007 17:45

confixx_vhost.conf und confixx_mhost.conf

Ah Confixx...

Sorry, dann kann ich dir nicht wirklich weiterhelfen. Du solltest in einem Confixx Support/User-Forum nachfragen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ahi » 30. January 2007 19:21

Ok dann schau ich mal weiter.....
vielen dank trotzdem nochmal
ahi
 
Posts: 13
Joined: 23. November 2006 12:46


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests