Apache2 startet nicht mit MySQL

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache2 startet nicht mit MySQL

Postby HELSEN » 30. January 2007 13:10

Hallo.
Ich habe ein (hoffentlich) kleines Problem.
Und zwar bekomme ich meinen Apache2 nicht mit MySQL "verknüpft".

Zuerst zum Verständnis ;) : Ich bin relativer Laie und "Fachidiot". Heist ich benutze nur die Tools, soweit ich es brauche.

Die Installation des Apache2 habe ich deshalb auch über WebMin durchführen lassen.
Nun wurde aber anscheinend nicht die Schnittstelle MySQL und PHP mitcompiliert.

PHPInfo gibt jedenfalls --without-mysql zurück.

Ich habe versucht, das mittels httpd.conf zu regulieren, indem ich die installierten Packets hier angegeben habe:

LoadModule php4_module /usr/lib/apache2/modules/libphp4.so
LoadModule auth_mysql_module /usr/lib/apache2/modules/mod_auth_mysql.so

Bei PHP hats auch wunderbar funktionert, jedoch nicht mit MySQL.

Die Frage die mich bewegt ist, kann ich über einen Startparameter oder eine andere Möglichkeit Apache2 zur Kommunikations mit MySQL bewegen, oder muss ich tatsächlich den Apache2-Server von Hand mit den entsprechenden Optionen compilieren?

Einige Infos:

Debian Sarge Linux R219234 2.6.17-cks1-rootserver
PHP Version 4.3.10-18
Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-18
MySQL 4.0.24-10sarge2

Danke + Gruß Harald
HELSEN
 
Posts: 5
Joined: 30. January 2007 12:59

Postby Wiedmann » 30. January 2007 14:37

LoadModule auth_mysql_module /usr/lib/apache2/modules/mod_auth_mysql.so

Ist aber etwas anderes als:
PHPInfo gibt jedenfalls --without-mysql zurück.

(sind für veschiedene Sachen da)

Was fehlt dir denn jetzt genau? (bzw. was willst du mit dem machen ws die fehlt)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby HELSEN » 30. January 2007 16:40

Wiedmann wrote:
LoadModule auth_mysql_module /usr/lib/apache2/modules/mod_auth_mysql.so

Ist aber etwas anderes als:
PHPInfo gibt jedenfalls --without-mysql zurück.

(sind für veschiedene Sachen da)

Was fehlt dir denn jetzt genau? (bzw. was willst du mit dem machen ws die fehlt)


Hmm. Stimmt. Jetzt fällts mir auch auf. *Stirnpatch* :D

Mir fehlt tatsächlich, das PHP nicht mit MySQL zusammen arbeitet.

Ist für ein kleines Statistikprogramm unter PHP. Aber das Programm kann halt die Datenbank nicht befüllen, weil die Kommunikation nicht stattfindet.

/Edit.
Muesste dann wohl in der PHP.INI irgendwo zu finden sein, denke ich mal
HELSEN
 
Posts: 5
Joined: 30. January 2007 12:59

Postby Wiedmann » 30. January 2007 17:17

Mir fehlt tatsächlich, das PHP nicht mit MySQL zusammen arbeitet.

Also fehlt dir die MySQL-Extension in PHP.

Wie hast du denn PHP installiert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby HELSEN » 30. January 2007 17:38

Auch über WebMin :)
Im Prinzip funktionierts ja, PHP Info gibt gute Werte ;).
Und in MYSQL habe ich auch schon die Tabellen und User angelegt
Es fehlt halt nur die MYSQL Verbindung in PHP

Ich habe jetzt mal das "php4-mysql" Packet installiert. und folgendes in der PHP.INI (in allen 3 vorsichtshalber :D) eingetragen:

extension_dir = "/usr/lib/php4/20020429"

Da liegt meine mysql.so (usr/lib/php4/20020429/mysql.so)

und
extension=mysql.so

Apache2 gestoppt/gestartet, kommt aber immer noch --without-mysql in der PHP Info.

Habe ich noch was übersehen, oder muss ich mal den Server neustarten, damit PHP das richtig initialisiert?
HELSEN
 
Posts: 5
Joined: 30. January 2007 12:59

Postby Wiedmann » 30. January 2007 17:43

und folgendes in der PHP.INI (in allen 3 vorsichtshalber)

phpinfo() sagt dir genau welche php.ini benutzt wird.

Code: Select all
extension_dir = "/usr/lib/php4/20020429"
extension=mysql.so

Soweit i.O. Nur stand das nicht schon da drin? (Eben durch die Installation des Paketes? Kenne aber auch Webmin nicht)
Was sagt denn phpinfo() zum "extension_dir"?

aber immer noch --without-mysql in der PHP Info.

Das ist korrekt. MySQL muss weiter unten als eigener MySQl-Abschnitt auftauchen, wie es sie für die anderen Extensions auch gibt (ABC sortiert).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby HELSEN » 30. January 2007 17:53

Wiedmann wrote:
und folgendes in der PHP.INI (in allen 3 vorsichtshalber)

phpinfo() sagt dir genau welche php.ini benutzt wird.

/etc/php4/apache2/php.ini
Das ist eine von denen welche ich upgedated habe.

Code: Select all
extension_dir = "/usr/lib/php4/20020429"
extension=mysql.so

Soweit i.O. Nur stand das nicht schon da drin? (Eben durch die Installation des Paketes? Kenne aber auch Webmin nicht)

Nein. Wurde nicht upgedated. Hab ich per Hand gemacht

Was sagt denn phpinfo() zum "extension_dir"?

extension_dir /usr/lib/php4/20020429
Also so wie eingetragen.
Oder muss ich es als "./usr/lib/php4/20020429" eintragen? Oder ohne ""?

aber immer noch --without-mysql in der PHP Info.

Das ist korrekt. MySQL muss weiter unten als eigener MySQl-Abschnitt auftauchen, wie es sie für die anderen Extensions auch gibt (ABC sortiert).
[/quote]

Hmm
Das hier vielleicht?:

Code: Select all
dbx
dbx support    enabled
dbx version    1.0.0
supported databases    
MySQL ODBC PostgreSQL Microsoft SQL Server FrontBase Oracle 8 (oci8) Sybase-CT


Sonst gibt es keine extra Sektion
HELSEN
 
Posts: 5
Joined: 30. January 2007 12:59

Postby HELSEN » 30. January 2007 17:58

YIPPIE. Es GEHT!!!
Vielen DANK!!!.

:mrgreen:


Manchmal muss man einfach nur in die richtige Richtung gedreht werden :D

Btw noch ein kleines Add-On Problem.
Irgend ein Packet hat mir mal ein Setting zerschossen, das in Putty die verschiedenen Attribute und Ordner farbig dargestellt werden.
Da gibts doch sicherlich auch irgendwo eine CFG, welche ich wieder entsprechend einstellen kann?
HELSEN
 
Posts: 5
Joined: 30. January 2007 12:59


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests