Alias auf externer Platte => Apache startet nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

Alias auf externer Platte => Apache startet nicht

Postby winusing » 28. January 2007 20:05

Hallo,

ich habe folgende Systemumgebung:

Windows XP, SP2
Apache 2.2.2 (ApacheFriends XAMPP (basic package) version 1.5.3a)
Interne Platte C:\
Externe Platte F:\

In der httpd.conf habe ich folgendes hinzugefügt:

Alias /alpha/knowhow f:/knowhow
<Directory f:/knowhow>
Options Indexes FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>

Ich kann mit http://servername/alpha/knowhow in das Verzeichnis. Die .htaccess von dort wird beachtet usw. Alles in bester Ordnung.

Nun ist diese externe Platte aber nicht immer angeschaltet. Dies hat leider den negativen Effekt, dass der Apache2-Service nicht startet und ein Ereignis 3299 loggt (Verz. f:/knowhow nicht gefunden).

Dies ist sehr unschön da ich den Apache auch gerne laufen hätte wenn die Platte nicht an ist da nur ein Bruchteil meines Intranets auf dieser Platte läuft.

Gibt es eine Möglichkeit dieses Verzeichnis so einzubinden, dass beim Start des Apache nicht geprüft wird ob dieses existiert?

Thomas
winusing
 
Posts: 2
Joined: 28. January 2007 19:03

Postby winusing » 02. February 2007 21:50

Scheinbar weiss keiner was :-(

Ich umgehe das ganz nun. Ich habe mir jetzt ein Directy-Listing von hier

http://www.evoluted.net/community/code/directorylisting.php

runtergeladen und leicht dahingehend modifiziert, dass nun auch absolute Laufwerksangaben funktionieren.

Da ich zufällig in den Zielverzeichnissen sowieso nur listen will und keine html-Seiten oder php-Skripte dort habe reicht mir das.

Sollte doch noch jemand eine Lösung haben wie man sowas mit Apache-Bordmitteln oder einem mod lösen kann bitte trotzdem posten!!!

Danke!

Thomas
winusing
 
Posts: 2
Joined: 28. January 2007 19:03


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests