Sicherheitsproblem mod rewrite ???

Alles, was den Apache betrifft, kann hier besprochen werden.

Sicherheitsproblem mod rewrite ???

Postby hawkmaster » 22. January 2007 09:32

Hallo zusammen,
ich habe den Apache 2.2.2 auf Windows.

Ich habe gelesen das es ein Sicherheitsproblem mit dem Module
mod rewrite geben soll.

Wenn nun in der httpd.conf dieses Modul garnicht aktiviert ist so wie unten:

#LoadModule rewrite_module modules/mod_rewrite.so

Kann ich dann diese Version des Apache einfach weiter betreiben ohne Gefahr?

vielen Dank
Gruss
hawk
hawkmaster
 
Posts: 94
Joined: 22. January 2004 12:33
Location: Stuttgart

Postby deepsurfer » 22. January 2007 10:53

Wäre gut wenn du den bewussten Artikel über das Sicherheitsloch mal als LINK hier posten würdest.

Zu deiner Frage:
Ja, solange das modul nicht für Apache aktiviert ist, ist es aus zu schliessen das durch ein eventuelles Sicherheitsloch über dieses module dein System kompromittiert wird.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

mod rewrite Sicherheitsmodul (mit Link)

Postby hawkmaster » 22. January 2007 11:11

Hallo Deep,
danke dir für deine Hilfe

Ich dachte das hier das Sicherheitsproblem schon bekannt ist, da es ja wohl schon eine Weile her ist.

Hier nun die Links zu den Infos:

http://httpd.apache.org/security/vulner ... es_22.html

http://www.tecchannel.de/news/themen/se ... index.html

In eurer 1.5.5 Version mit Apache 2.2.3 müsste das ja bereits behoben sein.
Ich will nicht unbedingt updaten, daher meine Frage:

viele Grüße
hawk
hawkmaster
 
Posts: 94
Joined: 22. January 2004 12:33
Location: Stuttgart


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests