Probleme mit Apache. konfiguerien der confs

Alles, was den Apache betrifft, kann hier besprochen werden.

Probleme mit Apache. konfiguerien der confs

Postby TomDebianfan » 20. January 2007 12:48

Hallo, ich habe ein änliches problem.. ich habe mir ein domain gekauft und habe auf mein Linux rechner (Debian) die neuste version apache installiert.. Nun sind alle einstellungen standarts. Jede config ist standard eingestellt. Mein problem ist jetzt: wenn ich jetzt www.meineadresse.de eingebe komm ich zur der seite www.meineadresse.de/apache2-default/ und da steht ein text das die webadresse erreichbar ist. wenn ich www.meineadresse.de/index.html eingebe komm ich auf meine seite... Das problem ist.. das die indext html nicht automatisch aufgerufen wird.. wo stelle ich das ein welche html die erste ist und automatsich aufgerufen wird? löschen der html seite von apache hat auch nix gebracht.. jetzt kommt wenn ich eingebe www.meineadresse.de --> nix nur wenn ich selbe verlinke zu meiner index html.. das ist doch scheiße.. bitte sagt mir wo ich das bei der apache version (Apache HTTP Server 2.2.4 von apache.de) für linux einstellen kann..
TomDebianfan
 
Posts: 4
Joined: 20. January 2007 12:39

Postby deepsurfer » 20. January 2007 13:07

das die indext html nicht automatisch aufgerufen wird.

Editiere die httpd.conf, suche nach
"DirectoryIndex default.html default.htm index.shtml ............................ "

Dann einfach an erster stelle index.html eintragen, abseichern, apache neu starten lassen und schon sollte bei dir eine index.html direkt geöffnet werden.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby TomDebianfan » 20. January 2007 13:59

Editiere die httpd.conf, suche nach
"DirectoryIndex default.html default.htm index.shtml ............................ "


meine httpd.conf ist im verzeichnis etc/apache2/httpd.conf gefunden habe ich die datei, aber die datei ist fast leer. screenshoot -->Image
kann es sein das bei der neustenversion die settings woanders sind ?
TomDebianfan
 
Posts: 4
Joined: 20. January 2007 12:39

Postby Wiedmann » 20. January 2007 14:59

kann es sein das bei der neustenversion die settings woanders sind ?

Jein.

Letztendlich liegt es an deiner speziellen Linuxdistribution wie und wo die Konfigdateien (aufgeteilt) sind.

(Und evtl. noch "Serververwaltungstools" installiert sind)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby TomDebianfan » 20. January 2007 17:21

ja gut, aber dann hat der tipp mir auch nix gebracht mit der httpd.conf editieren.. Was nu ? was kann ich denn jetzt machen ? :(
TomDebianfan
 
Posts: 4
Joined: 20. January 2007 12:39

Postby TomDebianfan » 20. January 2007 19:34

Editiere die httpd.conf, suche nach
"DirectoryIndex default.html default.htm index.shtml ............................ "


Ich glaube ich hab die richtige datei gefunden. bei mir heißt die nicht "httpd.conf" sondern "default" enthält aber nicht genau das was du oben beschrieben hast nach was ich suchen soll, aber ist sehr änlich und ich vermute wenn ich da was editiere, kann ich die index.html automatisch aufrufen,, problem ist.. wo soll ich da was editieren ? kennt sich jemand aus ?

Image
TomDebianfan
 
Posts: 4
Joined: 20. January 2007 12:39

Postby the_one » 27. October 2007 13:01

Bei Apache 2 heißt die Config wenn ich mich nicht irre doch apache2.conf und httpd.conf ist (uU fast) leer. Ich habe das gleiche Problem mit dem /apache2-default/, allerdings bin ich imemrhin schon soweit, dass er nihct mehr umleitet, sondern den inhalt des ordners anzeigt. Da gibt es nun analog/ und apache2-default/. Der Ordner ist allerdings leer. Wie bekomme ich das Weg? In analog/ sind nur ein paar komsiche Bilder drin. OS ist ebenfalls Debian.
the_one
 
Posts: 1
Joined: 27. October 2007 12:39


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests