User Directories

Alles, was den Apache betrifft, kann hier besprochen werden.

User Directories

Postby RLANG » 17. January 2007 13:58

Hallo,

nachdem ich nun mit der allgemeinen Hilfe mein erstes Problem gelöst bekam, ergibt sich ein neues. Hatte vor einiger Zeit schon mal unter WIN98 SE xampp installiert, in der Datei httpd.conf einen Verweis auf ein D. Laufwerk und zwei darin befindlichen Verzeichnissen gelegt.

Dies wollte ich hier heute auch machen, es geht nicht. Was mach ich falsch ?

folgendes hatte ich seinerzeit eingetragen

alias /anwendung "d:Anwendung /"
Order allow,deny
Allow from all

Dies habe ich jetzt sowohl in die xampp.conf als auch in die httpd.conf geschrieben, aber er fand dies URL nicht wie er sagte.

Kann mir jemand erklären, wie ich verschiedene Anwendungen auf dem Laufwerk D in verschiedenen Ordnern ausführen kann.

Der Zugriff soll nur im eigenen LAn möglich sein, nicht vom WWW herunter.

Gruß RLANG
RLANG
 
Posts: 31
Joined: 13. December 2006 18:22

Postby Wiedmann » 17. January 2007 14:10

alias /anwendung "d:Anwendung /"

Bist du sicher, dass du dich da nicht verschrieben hast?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RLANG » 17. January 2007 14:19

Hallo,

verschrieben das ich einen Slash vergessen habe,
es sollte so heißen Alias / Anwendung "D:/Anwendung /"

So lief das ganze mal, nun nicht mehr nach meiner neuen Installation.

Damals war der Ordner extra und die darin befindlichen Datein noch nicht vorhanden. Leider komme ich an diese Installation auch nicht mehr dran.

Aber egal, mus oder kann ich dieses Problem nur unter vhosts lösen, oder gibt es alternativ zu der damaligen Lösung etwas. Wie gesagt, es geht nur über einen InHouse Zugriff, also nur zum Testen der Applikation. Diese müssen aber auf verschiedenen Pfaden liegen.

Gruß RLANG
RLANG
 
Posts: 31
Joined: 13. December 2006 18:22

Postby Wiedmann » 17. January 2007 14:25

es sollte so heißen Alias / Anwendung "D:/Anwendung /"

Der Pfad "Anwendung " hat wirklich ein Leerzeichen an letzter Stelle?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RLANG » 17. January 2007 14:34

hallo,

nein nach Anwendung kommt sofort der Slash

........... Anwendung/"
RLANG
 
Posts: 31
Joined: 13. December 2006 18:22

Postby Wiedmann » 17. January 2007 15:36

Also hast du jetzt was genau in dieser Zeile stehen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RLANG » 17. January 2007 16:33

Hallo,

Hier noch einmal Zeichen für Zeichen der Eintrag

Alias /anwendung "d:/anwendung/"
<Directory "d:/anwendung">
Order allow,deny
Allow from all
</Directory>

So sieht es Zeichen für Zeichen aus.

Warum geht dies in der neuen Version nicht mehr.

Viele Grüße RLANG
RLANG
 
Posts: 31
Joined: 13. December 2006 18:22

Postby Wiedmann » 17. January 2007 16:47

Du merkst aber schon auch, dass sich das jetzt deutlich von deinem ersten Post unterscheidet?

Jedenfalls würde ich jetzt erst einmal sagen: so tut es.

- Das ganze hast du in der "httpd.conf" (in der richtigen)?
- Was zeigt der Browser genau für einen Fehlercode an?
- Was steht bei diesem Zugriff im "error.log"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RLANG » 17. January 2007 18:20

Hallo,

zu den Fragen
die datei httod.conf ist die im /xampp/Apache/conf/

Aufruf http//:localhost/anwendung


Fehlermeldung

Objekt nicht gefunden!
Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Wo ist der ERR-Log ?

Gruß RLANG


Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 404
localhost
01/17/07 18:33:18
Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0
RLANG
 
Posts: 31
Joined: 13. December 2006 18:22

Postby deepsurfer » 17. January 2007 19:04

Zusatzfrage:
Ist "d:" ein Netzlaufwerk oder eine Partition bzw. eigene Platte ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby RLANG » 17. January 2007 19:35

Hallo,

d ist eine eigene Platte

GRuß RLANG
RLANG
 
Posts: 31
Joined: 13. December 2006 18:22

Postby Wiedmann » 17. January 2007 20:17

Wo ist der ERR-Log ?

Im "Logs"-Verzeichnis? (o.ä.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RLANG » 17. January 2007 20:33

Hallo,

habe alle mir möglichen Varianten als Suchbegriff eingegeben,
eine solche Datei gibt es nicht. Was nun ?

Gruß RLANG
RLANG
 
Posts: 31
Joined: 13. December 2006 18:22

Postby Wiedmann » 17. January 2007 20:58

Die Datei heisst genau so, wie ich es oben gechrieben habe...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby RLANG » 17. January 2007 21:06

Hallo,

mittlerweile wurde ich durch Zufall fündig
Die Datei heißt error.txt und steht im Verzeichniss .....apache/logs

Obwohl ich den geschilderten eintrag gemacht habe

den da

Alias /Eltern-Portal "d:/P_TEST/Eltern-Portal/"
<Directory "d:/P_TEST/Eltern-Portal">
Order allow,deny
Allow from all
</Directory>

heißt die Fehlermeldung

[Wed Jan 17 21:16:27 2007] [error] [client 127.0.0.1] File does not exist: C:/Programme/xampp/htdocs/Eltern-portal
[Wed Jan 17 21:16:32 2007] [error] [client 127.0.0.1] File does not exist: C:/Programme/xampp/htdocs/Eltern-portal

Aufgerufen mit http//:localhost/eltern-portal

Laut Fehlermeldung interessiert ihn die alias definition nicht.

was mach ich nur falsch ?

Gruß RLANG
RLANG
 
Posts: 31
Joined: 13. December 2006 18:22

Next

Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests