Download Zugriff trotz .htaccess

Alles, was den Apache betrifft, kann hier besprochen werden.

Download Zugriff trotz .htaccess

Postby dark-neo » 10. January 2007 00:57

Hi,

ich habe ein Problem mit Apache2 und hoffe, dass mir hier jemand helfen kann. Heut Nachmittag hab ich von jemanden einen Link zu einem Download auf meinem Server (Rootserver), auf dem auch meine Website läuft bekommen. Das komische daran war, das er eigentlich "falsch" geschrieben war aber der Download trotzdem ging.

Mit Backslash -> h**p://w*w.meine-page.de\geschützter-Bereich\datei.rar

Der Bereich ist auch noch mit Benutzer und Passwort Abfrage per .htaccess geschützt.

Wie kann ich das unterbinden?

Danke
dark-neo
 
Posts: 4
Joined: 10. January 2007 00:43

Postby deepsurfer » 10. January 2007 01:16

- Windows oder Linux rootserver ?
- standalone Apache Installation oder Webserverpaket (wie XAMPP) ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby dark-neo » 10. January 2007 03:49

Linux rootserver (suse 9) und Apache2 standalone.
dark-neo
 
Posts: 4
Joined: 10. January 2007 00:43

Postby wandan » 10. January 2007 16:01

Hi.

Das kann eigentlich nur dann sein, wenn in der httpd.conf

AllowOverride None

in der entsprechenden Sektion eingetragen ist. Oder eins von den anderen Parametern was ein Override mittels .htaccess verhindert


Ansonsten kann es eigentlich höchstens noch ein Fehler in der .htaccess sein.

Sonst fällt mir da eigentlich nix ein.


Ich persönliche stelle die ganzen Security Sachen direkt in der httpd.conf ein,
dann hab ich alles an einer Stelle, und der Server muss nicht noch mit den htaccess dateien rummachen.

Grüße
Danny
wandan
 
Posts: 2
Joined: 08. January 2007 23:24

Postby dark-neo » 10. January 2007 16:15

hmm, hab kein "AllowOverride None" eingestellt, ich hab das so gemacht:

die .htaccess:

AuthType Basic
AuthName "secure-area"
AuthUserFile /etc/apache2/.htpasswd
AuthGroupFile /dev/null
require valid-user


die httpd.conf:

<Directory /srv/www/htdocs>
Options None
AllowOverride All
Order deny,allow
Allow from all
</Directory>

<Directory /srv/www/htdocs/geschützter Bereich>
AllowOverride AuthConfig
Options IncludesNoExec
Order allow,deny
Allow from all
</Directory>
dark-neo
 
Posts: 4
Joined: 10. January 2007 00:43

Postby dark-neo » 10. January 2007 16:48

Hab das Problem warscheinlich gefunden. Muß wohl daran gelegen haben. dass ich mich vorher schon mal mit nem richtigen Link einloggt hab. Aber eigentlich sollte die Abfage doch jedesmal kommen.

naja, Sorry

trotzdem Danke
dark-neo
 
Posts: 4
Joined: 10. January 2007 00:43

Postby martinpre » 10. January 2007 18:44

dark-neo wrote:Aber eigentlich sollte die Abfage doch jedesmal kommen.


Nein, den Benutzername und das Passwort wird vom Browser gecached ;)
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests