XAMPP/Tomcat 5.5.20 und JSDK 6?? Keiner eine idee?? help

Alles, was den Apache betrifft, kann hier besprochen werden.

XAMPP/Tomcat 5.5.20 und JSDK 6?? Keiner eine idee?? help

Postby flood » 07. January 2007 23:05

leider musst ich mein winxp system die tage neu aufsetzen...
jetzt wollt ich xampp + tomcat addon instalieren

xampp: kein thema läuft...

tomcat: naja braucht ja eig. JSDK 5.x...
nun steht aber das jsdk 6 zum download bereit... hab das jsdk 6 installiert...
wenn ich jetzt versuche tomcat zu installieren:
starte die

setup_xampp.bat:



########################################################################

# ApacheFriends XAMPP setup win32 Version 1.4.1 #

#----------------------------------------------------------------------#

# Copyright (c) 2002-2005 Apachefriends #

#----------------------------------------------------------------------#

# Authors: Kay Vogelgesang <kvo@apachefriends.org> #

# Carsten Wiedmann <webmaster@wiedmann-online.de> #

########################################################################


########################################################################

# ApacheFriends XAMPP Java add-on win32 Version 1.5 #

#----------------------------------------------------------------------#

# Copyright (c) 2002-2005 Apachefriends #

#----------------------------------------------------------------------#

# Authors: Kay Vogelgesang <kvo@apachefriends.org> #

# Oswald Kai Seidler <oswald@apachefriends.org> #

########################################################################

First note: Be sure that SUN J2EE 5.x SDK is installed!
German: Das SUN J2EE 5.x SDK muss installiert sein!
Checking status for setup (checke Status) ...


Do you want to setup this Java add-on for XAMPP? [y/n]: y

Searching SUN Java SDK now!


Sun J2SDK was not found!
Exit!
Drücken Sie eine beliebige Taste . . .


gibts irgendeine möglichkeit tomcat unter xampp zum laufen zu bringen??
oder mache ich irgendwas falsch??

hatte mit dem jsdk 5.x keine probleme gehabt

mfg

alex
flood
 
Posts: 1
Joined: 07. January 2007 22:47

Postby bombaclaude » 15. January 2007 01:41

Nein!
bombaclaude
 
Posts: 11
Joined: 01. January 2007 14:27

Postby KingCrunch » 15. January 2007 05:56

Du kannst die setup_xampp.bat manipulieren, dass er nicht mehr nach der Version prüft. Wenn du Glück hast, hat sich die API vom J2EE5 zu 6 nicht in den Umfang geändert, dass der Tomcat nicht mehr läuft, aber bei einem solchen Versionsprung in der Finalversionnummer halte ich das eher für unwahrscheinlich ...
Ansonsten: Zieh dir doch die J2EE 5, die es hier eigentlich noch geben sollte. (Ehrlich gesagt find ich da grad die 6 nicht :roll:)
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Workaround

Postby abacab » 09. February 2007 17:54

Also vorab, ich sehe keinen Grund, warum Tomcat 5.5 nicht mit Java SDK 6 laufen sollte.

Um das Tomcat-Addon von XAMPP mit Java 6 zu installieren, muss man die Datei javaaddon.php im Unterverzeichnis install etwas anpassen: Dort wird nämlich auf den Registry-Eintrag HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.5\JavaHome geprüft. Hier muss man einfach "1.5" durch "1.6" ersetzen.

Die Installation funktioniert dann wie gewohnt. Und nach einen kurzen Test kann ich sagen, dass Tomcat jetzt problemlos mit Java 6 läuft.
abacab
 
Posts: 1
Joined: 09. February 2007 17:41


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests