[gelöst]: Tomcat antwortet nicht mehr

Alles, was den Apache betrifft, kann hier besprochen werden.

[gelöst]: Tomcat antwortet nicht mehr

Postby hampa » 04. January 2007 10:39

Hallo Forum

Im Zuge eines Nachdiplomstudiums versuche ich Java zu lernen. :wink:
Aus diesem Grunde ist mein Wissen, was Java betrifft, eher begrenzt.

Ich Arbeite mit Eclipse 3.2.1, Tomcat 5.0.28 sowie Exadel Studio 4.0.2.

Die Aufgabenstellung lautet, dass mittels Struts eine "CRM"-Light Lösung programmiert wird.

Hier nun zu meinem Problem. Gestern Abend habe ich einige Stunden an meinem Projekt gewerkelt, als plötzlich beim Aufruf von http://localhost:8080/crmlight/ folgende Meldung erschien:

HTTP Status 500 -
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:372)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

root cause

java.lang.NullPointerException
org.apache.struts.taglib.TagUtils.computeURLWithCharEncoding(TagUtils.java:428)
org.apache.struts.taglib.TagUtils.computeURLWithCharEncoding(TagUtils.java:311)
org.apache.struts.taglib.logic.RedirectTag.generateRedirectURL(RedirectTag.java:294)
org.apache.struts.taglib.logic.RedirectTag.doEndTag(RedirectTag.java:268)
org.apache.jsp.index_jsp._jspx_meth_logic_redirect_0(index_jsp.java:83)
org.apache.jsp.index_jsp._jspService(index_jsp.java:59)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:324)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

note The full stack trace of the root cause is available in the Apache Tomcat/5.0.28 logs.


Ich habe leider keinen blassen schimmer woran es liegen könnte. Aufgetreten ist das Problem auf meinem Desktop zu Hause, der unter Ubuntu Linux läuft. Zuerst habe ich gedacht, dass es an Linux liegen könnte. Darum habe ich das Projekt exportiert und im Geschäft auf meinen Windows-Rechner importiert. Resultat: Genau dieselbe Meldung.

Ich erhalte nichteinmal mehr die Startseite des Tomcat-Servers mit http://localhost:8080/. Alles deutet daraufhin, dass es am Exadel-Studio liegen muss. Ich habe sogar versucht, innerhalb von Eclipse die Serverkonfiguration von Exadel zu löschen und einen neuen Server anzulegen. Das hat auch funktioniert. Bloss die Fehlermeldungen bleiben dieselben.

Ich bin euch für jeden Tip dankbar. Ich weiss leider nicht mehr weiter und muss bis am 15. Januar die Semesterarbeit abliefern. Man könnte sogar sagen, dass ich kurz vor der Verzweiflung stehe.

Viele Grüsse aus der Schweiz :cry:

Hampa
Last edited by hampa on 04. January 2007 11:42, edited 1 time in total.
User avatar
hampa
 
Posts: 2
Joined: 04. January 2007 10:36
Location: Graubünden, Schweiz

Postby hampa » 04. January 2007 11:41

Sorry Leute

Das Problem hat sich erledigt. Ich habe bloss ein FormBean gelöscht und dessen Namen aus einem Action-mapping entfernt und schon lief die ganze Sache wieder.

Es scheint mir jedoch sehr problematisch zu sein, dass ein klitzekleiner Fehler in der Konfiguration im sturts-config.xml dazu führt, dass sich der Tomcat-Server nicht mehr korrekt starten lässt.

Grüsse und nichts für ungut

Hampa
Lieber unvollkommen als total fertig.
User avatar
hampa
 
Posts: 2
Joined: 04. January 2007 10:36
Location: Graubünden, Schweiz


Return to Apache

Who is online

Users browsing this forum: No registered users and 6 guests