Probleme beim OpenSSL

Alles, was den Apache betrifft, kann hier besprochen werden.

Probleme beim OpenSSL

Postby otto-mueller » 03. January 2007 23:33

Hallo zusammen,

ich habe folgendes Problem:

Mein System:
- Windows XP Pro
- WAMP (Apache 1.3.37)

Ich habe nach folgender Anleitung (http://www.apache-wamp.de/download_uebersicht.html letzter Abschnitt) SSL konfiguriert.

Wenn ich nun Apache starten möchte, bekomme ich folgende Fehlermeldung:

Code: Select all
C:\Programme\Apache Group\Apache>apache -k start
Syntax error on line 203 of c:/programme/apache group/apache/conf/httpd.conf:
Cannot load c:/programme/apache group/apache/mod_ssl.so into server: (127) Die angegebene Prozedur wurde nicht gefunden:


Zeile 203 ist folgende:
Code: Select all
LoadModule ssl_module mod_ssl.so


Weiss jemand, woran es hängt???

Bitte um Hilfe.

Vielen Dank vorab

Gruß
Otto
otto-mueller
 
Posts: 6
Joined: 24. December 2006 21:23

Postby deepsurfer » 03. January 2007 23:45

Code: Select all
Cannot load c:/programme/apache group/apache/mod_ssl.so into server: (127) Die angegebene Prozedur wurde nicht gefunden:


Wie aus der Fehlermeldung zu lesen wird versucht das mod_ssl.so aus einem Pfad zu laden wo diese Datei nicht vorhanden ist.

Schau mal nach wo diese mod_ssl.so genau liegt und ändere entsprechende den Pfad in deiner httpd.conf

Wenn ich mich jetzt recht erinnere liegen die module in einem unterpfad mit dem namen "modules".
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 04. January 2007 03:50

Cannot load c:/programme/apache group/apache/mod_ssl.so into server: (127) Die angegebene Prozedur wurde nicht gefunden:

Das "mod_ssl.so" das du da hast, passt nicht zu deiner Apache-Version.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby otto-mueller » 04. January 2007 15:52

Hallo zusammen,

erstmal vielen Dank für die Antworten.

deepsurfer wrote:
Code: Select all
Cannot load c:/programme/apache group/apache/mod_ssl.so into server: (127) Die angegebene Prozedur wurde nicht gefunden:


Wie aus der Fehlermeldung zu lesen wird versucht das mod_ssl.so aus einem Pfad zu laden wo diese Datei nicht vorhanden ist.

....


Das mod_ssl.so ist direkt unter Apache-Verzeichnis vorhanden - also das ist schon mal richtig. Sonst würde ich folgende Fehlermeldung bekommen:
Code: Select all
C:\Programme\Apache Group\Apache>apache -k Start
Syntax error on line 203 of c:/programme/apache group/apache/conf/httpd.conf:
Cannot load c:/programme/apache group/apache/mod_ssl.so into server: (126) Das angegebene Modul wurde nicht gefunden:



Wiedmann wrote:
Cannot load c:/programme/apache group/apache/mod_ssl.so into server: (127) Die angegebene Prozedur wurde nicht gefunden:

Das "mod_ssl.so" das du da hast, passt nicht zu deiner Apache-Version.


Ich denke auch, daß es tatsächlich daran liegt, aber wie und woher finde ich denn ein passendes ssl-Modul? Oder muss ich es selber kompilieren - wie würde ich es denn machen?

Danke nochmal

Gruß
Otto
otto-mueller
 
Posts: 6
Joined: 24. December 2006 21:23

Ergänzung ...

Postby otto-mueller » 05. January 2007 00:07

Hallo nochmal,

ich habe auf der mod_ssl.org Seite die passende mod_ssl Version zu meinem Apache 1.3.37 gefunden
http://www.modssl.org/
http://www.modssl.org/source/mod_ssl-2.8.28-1.3.37.tar.gz

Aber in diesem Paket finde ich keine mod_ssl.so Datei. Es sind mod_ssl.h und mod_ssl.c da aber *.so nicht!

Es gibt auch keine Installationsdatei oder ähnliches in diesem Paket.

Eine Configure.bat Datei gibt es dort, wenn ich es ausführe, kommt die Fehlermeldung ".. Der Befehl "Perl" wurde nicht gefunden ...

Was mache ich denn jetzt???

Gruß
Otto
otto-mueller
 
Posts: 6
Joined: 24. December 2006 21:23

Postby Wiedmann » 05. January 2007 01:21

Aber in diesem Paket finde ich keine mod_ssl.so Datei. Es sind mod_ssl.h und mod_ssl.c da aber *.so nicht!

Das ist der Quellcode von diesem Modul zum Kompilieren.

Was mache ich denn jetzt???

Entweder du kompilierst dir das Modul (bei deinen Fragen wohl eher nicht ...), oder du suchst im Netz wo es ein fertiges Modul für deinen Apachen gibt (so als Tip schätze ich mal, dass Hunter dieses Modul hat).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby otto-mueller » 05. January 2007 08:59

Hallo,

Wiedmann wrote:Entweder du kompilierst dir das Modul (bei deinen Fragen wohl eher nicht ...), oder du suchst im Netz wo es ein fertiges Modul für deinen Apachen gibt (so als Tip schätze ich mal, dass Hunter dieses Modul hat).


Wie kompiliere ich es denn? gibt es irgendwo eine Anleitung/Hilfe dazu?

Im Netz habe ich lange danach gesucht, aber bisher habe ich leider keine passende Version gefunden :cry:

Was oder wer ist denn Hunter und wo finde ich es denn?

Gruß
Otto
otto-mueller
 
Posts: 6
Joined: 24. December 2006 21:23

Hilfeeeeeeeee!!!!!

Postby otto-mueller » 13. January 2007 20:43

Hallo zusammen,

kann mir keiner helfen????

Bitte ich brauche dringend Hilfe, um dieses Problem zu lösen ....

Danke nochmal

Gruß
Otto
otto-mueller
 
Posts: 6
Joined: 24. December 2006 21:23


Return to Apache

Who is online

Users browsing this forum: No registered users and 2 guests