Apache liefert im Http-Header falsche Uhrzeit aus

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache liefert im Http-Header falsche Uhrzeit aus

Postby gtq » 18. December 2006 15:40

Hallo,

mein erster Beitrag hier - ich hab zu meiner Frage die Suche genutzt, jedoch ohne befriedigendes Ergebnis - also bitte nicht gleich schimpfen wenn das evtl. doch schon besprochen wurde :mrgreen:

Folgendes Problem:
Mein Apache liefert im Response-Header eine falsche Uhrzeit aus - der ist um 5 Stunden im voraus. Systemzeit stimmt wenn ich auf der Konsole mit date oder in PHP mit date(); die Zeit anzeigen lasse.

Das Problem dabei ist, dass dadurch ein Browser natürlich sämtliche Einstellungen zum Caching ignoriert (da auch die Zeit für den Exires-Header falsch berechnet wird) und jede kleine Grafik die z.B. 15 Mal auf ner html-Seite vorkommt jedesmal aufs neue Requestet :? - das ist natürlich nicht so toll für die Performance, besonders dann, wenn jemand auf ner langsameren Leitung wie ISDN unterwegs ist.

Prüfe ich das access_log des Apachen stimmt die Zeit, allerdings wird nachfolgend -0500 angegeben.

Sieht also irgendwo so aus als gäbe es eine Directive o.Ä. in der .conf die da evlt. falsch gesetzt ist.

Nur find ich weder in Google oder hier z.B. weitere Infos ob es dazu Einstellungsmöglichkeiten gibt - habe auch mit der httpd.conf von anderen Servern verglichen, die die korrekte Zeit ausliefern. Ich lauf an dieser Stelle gegen eine Wand - hat jemand ne Ahnung was ich noch machen könnten bzw. wo ich noch schauen könnt? Der Server-Support macht sich zu dem Thema auch rar :x

Gruß
gtq
gtq
 
Posts: 2
Joined: 18. December 2006 15:20

Postby deepsurfer » 18. December 2006 18:02

- Bei allen Server wo du etwas abrufst oder nur bei einem ?

- liegt ein Proxy zwischen den Servern und deiner Leitung ?


Bringt dir das hier enthaltene Script beispiel etwas ?
http://suchmaschinentricks.de/forum/thr ... 27&forum=1

- Werden die Daten die du da Abrufts mittels CURL auf den Server hochgeladen ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby gtq » 18. December 2006 23:01

Hallo,

danke für die Antwort.

Es handelt sich um einen physikalischen Server mit Apache als Webserver und ca. 50 V-Hosts. Alle V-Hosts auf dieser Maschine sind von dem Problem betroffen. Ich habe 5 weitere Server bei einem anderen Reseller-Provider die ähnlich konfiguriert sind und sich im großen und ganzen nur durch die web-Admin-Oberfläche unterscheiden - der der Probleme macht hat eine BlueQuartz Admin-Oberfläche.

Dynamisches Ändern der Date und Expires-Header wie in deinem Link bringt nichts - da müsst ich ja für jeden Datei-Typen den PHP-Parser anschmeissen und die Header setzen lassen - wär ein bisschen "Overkill" :mrgreen:

Die Daten werden mit WS-FTP geupped.

Wie gesagt - die Systemzeit der Maschine stimmt - date auf Konsole oder als PHP date(); liefert stets die korrekte Zeit - nur der Apache ist bei seinen Headern der aktuellen Zeit stets um genau 5 Stunden vorraus.

Es muss eigentlich irgendwas mit der Konfig des Apachen zu tun haben - alles andere an Software nimmt die richtige Zeit her - z.B. auch ne Current-timestamp-Spalte in ner MySql-Tabelle wenn man nen Datensatz einfügt oder ändert.

Aja - nen Proxy hab ich im Webbrowser nicht aktiv geschaltet - die Daten sollten also stets "frisch" vom Server kommen - bei meinen anderen Maschinen kommt im Header ja auch stets die korrekte Zeit - Proxys schließe ich daher als Ursache aus.
gtq
 
Posts: 2
Joined: 18. December 2006 15:20


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests