Emails über PHP versenden ist extrem inperformant

Alles, was den Apache betrifft, kann hier besprochen werden.

Emails über PHP versenden ist extrem inperformant

Postby Der Anfänger » 17. December 2006 13:15

Hallo!

Ich habe auf meinem Live Server ein Problem beim senden von Emails über eine PHP Klasse. Diese Klasse läuft auf mindestens 10 Servern absolut performant, u.a. auch auf dem Testserver, der ein genaues Abbild des Live WebServers ist.

Auf dem Live Server dauert das Senden einer Email teilweise 2 min. (nach drücken eines Buttons) obwohl es sich nur um ein wenig Text handelt .. auf jedem der anderen Server ist das Senden in weit unter einer Sekunde durch.

Der Provider hatte letztens etwas am Apache gedreht und dann ging es wieder eine Zeit lang, jetzt wieder das Problem .. auf mehrfaches Drängen beteuerte der Provider, das wäre doch alles ganz normal .. also ich gewinne langsam den Eindruck der hat überhaupt keinen Plan .. und Lust zu helfen schon überhaupt nicht. :?

Kann mir jemand einen Tip geben, woran das liegen kann?

Braucht Ihr noch mehr Infos? Einfach sagen.

Vielen Dank!
Der Anfänger
 
Posts: 6
Joined: 17. December 2006 12:45

Postby deepsurfer » 17. December 2006 14:01

Du beschrfeibst das der zweite Server eine 1 zu 1 kopie des ersten server ist.

Ich denke das der zweite Server nun eine andere IP und Domain aufweist, aber deine Scripte durch das 1 zu 1 immer noch mit den alten angaben arbeiten, dadurch passieren Auflösungsprobleme die dieses Zeitliche Verzögern erklären würden.

Mal mit tail -f --logifle-- über konsolenzugang in echtzeit nachlesen was da passiert.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Der Anfänger » 17. December 2006 14:35

deepsurfer wrote:Du beschrfeibst das der zweite Server eine 1 zu 1 kopie des ersten server ist.

Ich denke das der zweite Server nun eine andere IP und Domain aufweist, aber deine Scripte durch das 1 zu 1 immer noch mit den alten angaben arbeiten, dadurch passieren Auflösungsprobleme die dieses Zeitliche Verzögern erklären würden.


Der Live Server wurde auf den Testserver kopiert, soll heissen die Kopie läuft einwandfrei, aber das original nicht. Wir haben das Problem auch soweit eingegrenzt, dass irgendwas auf dem Live Server buggy ist .. das Skript läuft ja auf allen anderen Servern einwandfrei.


deepsurfer wrote:Mal mit tail -f --logifle-- über konsolenzugang in echtzeit nachlesen was da passiert.


Danke, super Tip, ... leider finde ich keinen log .. wo sollte der denn liegen .. bin leider kompletter Anfänger diesbezüglich! :oops:
Der Anfänger
 
Posts: 6
Joined: 17. December 2006 12:45

Postby Der Anfänger » 17. December 2006 14:40

.. bzw., ich glaube unter /var/log/...

aber welchen log sollte ich scannen, habe maillog, maillog1, .., maillog4?
Der Anfänger
 
Posts: 6
Joined: 17. December 2006 12:45

Postby Der Anfänger » 17. December 2006 14:44

So, ok, ich glaube ich habe es .. in maillog wurde folgendes geschrieben:

Dec 17 14:35:58 ... sendmail[2304]: kBHDZMdF002304: from=<nobody@...>, size=528, class=0, nrcpts=1, msgid=<200612171335.kBHDZ7hT002297@...>, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1]
Dec 17 14:35:58 ... sendmail[2297]: kBHDZ7hT002297: to=..., ctladdr=nobody (99/99), delay=00:00:51, xdelay=00:00:36, mailer=relay, pri=30252, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (kBHDZMdF002304 Message accepted for delivery)
Dec 17 14:36:11 ... procmail[2307]: Error while writing to "/var/log/procmail"
Dec 17 14:36:11 ... spamc[2313]: connect() to spamd at 127.0.0.1 failed, retrying (1/3): Connection refused
Dec 17 14:36:12 ... spamc[2313]: connect() to spamd at 127.0.0.1 failed, retrying (2/3): Connection refused
Dec 17 14:36:13 ... spamc[2313]: connect() to spamd at 127.0.0.1 failed, retrying (3/3): Connection refused
Dec 17 14:36:14 ... spamc[2313]: connection attempt to spamd aborted after 3 retries
Dec 17 14:36:14 ... sendmail[2306]: kBHDZMdF002304: to=<...>, ctladdr=<nobody@...> (99/99), delay=00:00:27, xdelay=00:00:16, mailer=local, pri=30784, dsn=2.0.0, stat=Sent
Der Anfänger
 
Posts: 6
Joined: 17. December 2006 12:45

Postby Der Anfänger » 20. December 2006 14:37

ale hopp ..

Kann bitte jemand helfen!

Vielen Dank!
Der Anfänger
 
Posts: 6
Joined: 17. December 2006 12:45

Postby Kozzah » 20. December 2006 14:50

Warum liest du nicht das logfile?

Es steht dort doch:

Code: Select all
Dec 17 14:36:11 ... spamc[2313]: connect() to spamd at 127.0.0.1 failed, retrying (1/3): Connection refused
Dec 17 14:36:12 ... spamc[2313]: connect() to spamd at 127.0.0.1 failed, retrying (2/3): Connection refused
Dec 17 14:36:13 ... spamc[2313]: connect() to spamd at 127.0.0.1 failed, retrying (3/3): Connection refused


Deine Maschine versucht mehrmals, die zu versendende E-Mail durch einen Spamfilter zu schicken, was nicht klappt, weil der Spamfilter entweder nicht läuft oder dein User nicht das Recht hat, ihn zu benutzen.
Code: Select all
Dec 17 14:36:14 ... spamc[2313]: connection attempt to spamd aborted after 3 retries

Nach dem dritten Fehlversuch bricht er ab...
Code: Select all
Dec 17 14:36:14 ... sendmail[2306]: kBHDZMdF002304: to=<...>, ctladdr=<nobody@...> (99/99), delay=00:00:27, xdelay=00:00:16, mailer=local, pri=30784, dsn=2.0.0, stat=Sent

...um mit dem weiter zu machen, was er eigentlich tun sollte.

Also - entweder das Konfigurationsproblem mit dem Spamfilter lösen, oder den Spamfilter runterhauen.
Kozzah
 
Posts: 14
Joined: 19. December 2006 10:11

Vielen Dank

Postby Der Anfänger » 28. December 2006 17:07

Vielen Dank für Eure Hilfe!!!

Habe das Problem Dank Eurer Hilfe lösen können, obwohl ich davon eigentlich überhaupt keine Ahnung habe .. klasse Forum!! :)

Mein Provider hat das seit ca. 3-4 Wochen nicht geschafft, obwohl es sich um einen Managed Server handelt (übrigens bei internet4ever) :evil:

Das ist wirklich traurig.
Der Anfänger
 
Posts: 6
Joined: 17. December 2006 12:45


Return to Apache

Who is online

Users browsing this forum: Peterzzz and 3 guests