Es geht mal um AWStats

Alles, was den Apache betrifft, kann hier besprochen werden.

Es geht mal um AWStats

Postby rkami » 13. December 2006 00:46

Hallo Forum,

Auf meinem PC ist Windows XP Pro installiert. Auf meinem PC habe ich einen Apache-Server installiert. Diese Locks möchte ich nun mit dem AWStats ansehen können. Leider bekomme ich immer eine Fehlermeldung:

Hier die Fehlermeldung im Explorer:
couldn't create child process: 720003: awstats.pl

Das ist der Access.log
192.168.1.3 - - [12/Dec/2006:23:23:39 +0100] "GET /cgi-bin/awstats.pl?config=kami HTTP/1.1" 500 1235


Das ist der Error.log
[Tue Dec 12 23:23:39 2006] [error] [client 192.168.1.3] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't create child process: 720003: awstats.pl
[Tue Dec 12 23:23:39 2006] [error] [client 192.168.1.3] (OS 3)Das System kann den angegebenen Pfad nicht finden. : couldn't spawn child process: F:/apache/xampp/cgi-bin/awstats.pl


Da hier bestimmt Kenner dieses Programmes in den Reihen sind hoffe ich auf eine Hilfe. Ich finde die Einstellung nicht, die bewirkt, dass diese Fehlermeldung verursacht: F:/apache/xampp/cgi-bin/awstats.pl.
Oder muss noch in der httpd.conf eine Einstellung gemacht werden.
Ich habe das XAMPP installiert.

mfg
kami
rkami
 
Posts: 37
Joined: 10. January 2006 15:59
Location: Düsseldorf

Postby Wiedmann » 13. December 2006 01:03

Du wirst in der "awstats.pl" den SheBang anpassen müssen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rkami » 13. December 2006 09:50

Mit welchem Programm muss ich denn das machen?
Im Editor sehe ich zwar dass es ein Textbasierte Datei ist, aber unformatiert.

mfg
kami
rkami
 
Posts: 37
Joined: 10. January 2006 15:59
Location: Düsseldorf

Postby rkami » 13. December 2006 10:54

Hallo,

habe die Datei gefunden. Kann jetzt richtig die .pl-Datei lesen. Mit dem Programm PHPEdit. Wie muss ich den "awstats.pl" den SheBang anpassen.
Was ist ein SheBang. Den Begriff habe ich in der awstats.pl nicht gefunden. Von .pl habe ich leider keine Ahnung. Bitte helft mir.

mfg
kami
rkami
 
Posts: 37
Joined: 10. January 2006 15:59
Location: Düsseldorf

Postby rkami » 14. December 2006 20:34

Wiedmann wrote:Du wirst in der "awstats.pl" den SheBang anpassen müssen.



Nun diesen SheBang habe ich in der httpd.conf gefunden.
Welche Anpassungen muss ich da einstellen.

hier die error.log
[Thu Dec 14 20:23:54 2006] [error] [client 192.168.1.3] client denied by server configuration: M:/apache/xampp/htdocs/cgi-bin

hier die access.log
192.168.1.3 - - [14/Dec/2006:20:23:54 +0100] "GET /cgi-bin/awstats.pl?config=kami HTTP/1.1" 403 1206


Wer kann mir noch helfen?

mfg
rkami
rkami
 
Posts: 37
Joined: 10. January 2006 15:59
Location: Düsseldorf

Postby rkami » 16. December 2006 21:41

... nach langen Nächten habe ich das SheBang gefunden.

Habe nochmals ActivePerl und AWStats installiert.
Perl habe ich erst auf Funktion kontrolliert: perl cgi.cgi ist jetzt OK.
Habe soweit auch das AWStats zum aufrufen gebracht.
Leider sind die Daten aber nicht zu sehen. Alles NULL.
Ein Updatestats habe ich auch unternommen. Alles ohne Erfolg.
Die Datei awstats.pl funktioniert unter DOS, aber ich sehe nicht wohin die Daten geschrieben werden.

mfg
rkami
rkami
 
Posts: 37
Joined: 10. January 2006 15:59
Location: Düsseldorf


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests