Apache 1.3 mit PHP 4 unter Unixware als Nicht-root-Benutzer

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache 1.3 mit PHP 4 unter Unixware als Nicht-root-Benutzer

Postby Efchen » 08. December 2006 14:28

Moin zusammen,

ich habe das Problem, dass ich unter Unixware 7 einen Apache mit PHP und mySQL zum Laufen bringen möchte und das irgendwie nicht klappt.

Ich habe Apache 1.3.26, installiert in /usr/lib/apache/, worauf ich nur Lesezugriff habe. Folglich habe ich mir ein eigenes httpd.conf zusammengestellt. Ohne PHP funktioniert das alles wunderprächtig.

Kommen wir zu PHP. Die Installation von PHP (hab nicht ich gemacht, müsste 4.1? sein) hat in die httpd.conf
Code: Select all
LoadModule php4_module        libexec/libphp4.so
AddModule mod_php4.c

eingetragen. Die libphp4.so liegt auch unter /usr/lib/apache/libexec, wie angegeben.
Wenn ich nun Apache starten will, kommt diese Fehlermeldung:
Code: Select all
Cannot load /usr/lib/apache/libexec/libphp4.so into server: dynamic linker : /usr/lib/apache/bin/httpd : could not open /usr/local/pgsql/lib/libpq.so.2

Weder gibt es auf diesem System ein /usr/local/pgsql, noch gibt es irgendwo eine libpq.so.2. Nach ein bisschen rumgooglen würde ich vermuten, dass das was mit Postgress zu tun hat, aber damit hab ich nichts am Hut, wie kommt er dazu, diese Library zu verlangen?

Und was geht hier überhaupt schief?

Vielen Dank für aufklärende Tipps!
-Efchen
Efchen
 
Posts: 11
Joined: 07. December 2006 10:36

Postby Efchen » 15. December 2006 15:43

Es scheint mir irgendwie so, dass libpq.so.2 ja wohl zu Postgress gehört und der Apache irgendwie so konfiguriert ist, dass er Postgress braucht. Kann man das auch irgendwie abstellen? Ihm sagen, dass kein Postgress da ist und er nicht danach gucken muss?

Danke,
-Efchen
Efchen
 
Posts: 11
Joined: 07. December 2006 10:36


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests