httpd.conf

Alles, was den Apache betrifft, kann hier besprochen werden.

httpd.conf

Postby rabby » 02. December 2006 15:46

hallo,

hätte gerne eine art catch-all subdomains, sodass bei einem aufruf von z.b. test.testserver.tld oder anderer-test.testserver.tld .../htdocs/subdomain-projekt/ verwendet (nicht weitergeleitet!) wird.
bei testserver.tld allein soll natürlich .../htdocs/ das root dir sein.

danke für tipps
Zune-Shop & Garantieerweiterung für Zune Player
rabby
 
Posts: 28
Joined: 15. December 2003 17:39

Postby Wiedmann » 02. December 2006 15:59

Wie gehabt 2 VHosts defnieren.

Der 1. wird schon prinzipbedingt zum catch-all (default) Host, und den 2. konfigurierst du ausdrücklich für "testserver.tld".

(Beispiele für VHosts findest du im Forum massenhaft)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 02. December 2006 16:07

Dazu zwei VHOSTS erstellen, der allerste wird dann deine "subdomain-projekt" sein, der zweite eintrag ist deine normale domain und dessen Webcontent.

Hintergrund:
Der Apache leitet alles was er nicht selber Auflösen kann an den ersten VHOSTS eintrag.

mögliches aussehen deines Wunsches:

Code: Select all

NameVirtualHost *.80

<VirtualHost *.80>
    ServerName *.testserver.tld
    ServerAdmin webmaster@testserver.tld
    DocumentRoot /aaa/bbb/ccc/htdocs/subdomain-projekt
<Directory "/aaa/bbb/ccc/htdocs/subdomain-projekt">
AllowOverride All
        Options IncludesNoExec
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>

<VirtualHost *.80>
    ServerName testserver.tld
    ServerAlias www.testserver.tld
    ServerAdmin webmaster@testserver.tld
    DocumentRoot /aaa/bbb/ccc/htdocs
<Directory "/aaa/bbb/ccc/htdocs">
AllowOverride All
        Options IncludesNoExec
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>




Wenn du PLESK oder CONFIXX als AdminWebinterface hast, so ist dort eine solche Funktion im Bereich "Domain" einstellbar.

Subanweisung: *
Auswahl Domain: testserer.tld
Pfad: /subdomain-projekt

Deine normale testserver.tld ist ja mit /htdocs verbunden.

Steht aber auch in der Anleitung des Webinterfaces.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby rabby » 02. December 2006 16:32

hab das mal angepasst und eingebunden:
[Sat Dec 02 15:32:59 2006] [error] (EAI 2)Name or service not known: Could not resolve host name *.80 -- ignoring!
[Sat Dec 02 15:32:59 2006] [warn] NameVirtualHost *:80 has no VirtualHosts
rabby
 
Posts: 28
Joined: 15. December 2003 17:39

Postby deepsurfer » 02. December 2006 20:47

Upps.... auch grad gesehen, hab Punkt statt doppelpunkt drin stehen...sorry.

Könntest du bitte die komplette Section deiner VHOST Definition hier posten.
Denn nach dem Logauszug sieht es aus das du da was falsch gemacht hast.
(spezische adressen einfach abändern)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby rabby » 02. December 2006 21:16

ok, also nun kommt der fehler nicht mehr.
doch die subdomains gehen immernoch nicht

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName dev
    ServerAdmin webmaster@testserver.tld
    DocumentRoot /var/www/htdocs/test
<Directory "/var/www/htdocs/test">
AllowOverride All
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>
<VirtualHost *:80>
    ServerName server
#    ServerAlias www.testserver.tld
    ServerAdmin webmaster@testserver.tld
    DocumentRoot /var/www/htdocs
<Directory "/var/www/htdocs">
AllowOverride All
#        Options IncludesNoExec
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>


Der Server wird aufgerufen, wenn im lokalen Netzwerk http://server oder http://dev angefragt wird. Das wurde über die hosts der entsprechenden Rechner geregelt.
"server" soll weiterhin htdocs als root dir haben.
"dev" hingegen soll htdocs/test verwenden und noch dazu sollen alle subdomains, also *.dev ebenfalls /test nehmen.
rabby
 
Posts: 28
Joined: 15. December 2003 17:39

Postby deepsurfer » 02. December 2006 22:01

ok, also nun kommt der fehler nicht mehr.
doch die subdomains gehen immernoch nicht


http://dev geht !
http://server geht !
http://test.dev geht nicht.

Ist denn auch in den HOSTS der LANrechner auch
Code: Select all
*.dev IP

Definiert. (Habs nicht getestet ob die HOSTS bei externen PC dies auch so umsetzen)
Denn wenn nur
Code: Select all
dev IP

Definiert ist können keine subs benutzt werden und würde eigentlich immer eine Fehlermeldung hervorrufen.

VHOST Verbesserung:
Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName *.dev   #Ausbesserung für subs anfragen
    ServerAlias dev  #Ausbesserung damit dev anerkannt wird
    ServerAdmin webmaster@testserver.tld
    DocumentRoot /var/www/htdocs/test
<Directory "/var/www/htdocs/test">
AllowOverride All
        Order allow,deny
        Allow from all
</Directory>
</VirtualHost>

zweiter Eintrag ist Ok..

Bestehen die anderen PC im LAN auch aus Linux Betriebssystem ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby rabby » 02. December 2006 22:16

hallo,

sags mir bitte, wenn ich mich täusche, doch es muss doch ip name lauten, oder? (reihenfolge)

auf dem server selbst habe ich in der hosts das hinzugefügt:
192.168.1.103 server dev *.dev


server und dev geht, aber nicht die subdomains, trotz der verbesserung der vhost datei. da auch nicht der zugriff vom server auf sich selbst mittels lynx http://test.dev/ funktioniert, ist es zweifelhaft, ob die vhost so stimmt.
rabby
 
Posts: 28
Joined: 15. December 2003 17:39

Postby deepsurfer » 03. December 2006 00:46

jo.... kann ich reproduzieren.
Ich vermute das es ohne DNSserver so nicht funktioniert da die HOSTS einträge solche Differenzierungen nicht zulässt und daher nicht weitergegeben werden.

Wenn ich es jetzt noch schaffe baue ich noch einen Bind9 in meine Testumgebung auf um zu checken ob ich mit meiner Vermutung richtig liege.
(Ich verspreche jetzt hier nichts, würde mich aber dann nochmal melden ob ich es hinbekommen habe)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 03. December 2006 02:10

server und dev geht, aber nicht die subdomains, trotz der verbesserung der vhost datei. da auch nicht der zugriff vom server auf sich selbst mittels lynx http://test.dev/ funktioniert, ist es zweifelhaft, ob die vhost so stimmt.

Mit den VHosts die du hier definiert hast, funktioniert genau das was du willst:
"server" soll weiterhin htdocs als root dir haben.
"dev" hingegen soll htdocs/test verwenden und noch dazu sollen alle subdomains, also *.dev ebenfalls /test nehmen.

Apacheseitig (also das Thema dieses Forums) ist jetzt alles in Ordung.

Aber:
Das wurde über die hosts der entsprechenden Rechner geregelt.

HOSTS-Dateien kennen keine Wildcards (*).
Entweder du trägst jede Subdomain von "dev" separat in die HOSTS-Dateien ein, oder du benutzt einen DNS-Server der Wildcards unterstützt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 03. December 2006 02:48

Wiedmann wrote:HOSTS-Dateien kennen keine Wildcards (*).
Entweder du trägst jede Subdomain von "dev" separat in die HOSTS-Dateien ein, oder du benutzt einen DNS-Server der Wildcards unterstützt.

Jup...dachte ich es mir doch.

Das meine Ausgebesserte VHOSTS section driss war ist mir auch jetzt klar.
(mist, immer diese kleinigkeiten ;) )

greets
Deep
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests