Apache 2.2 Verzeichnisschutz Problem

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache 2.2 Verzeichnisschutz Problem

Postby Chummer76 » 24. November 2006 23:17

Halli Hallo !

Folgendes Problem ist bei mir aufgetaucht:

Egal welche Restriktionen ich anlege, Apache interpretiert immer nur Zugriff erlaubt/nicht erlaubt, ob in der httpd.conf oder in der .htaccess des Verzeichnisses

Eigentlich sollte bei AllowOverride AuthConfig in der <Directory> Section und einer AuthType Basic in der .htaccess eine Passwortabfrage erscheinen... doch irgendwie scheine ich immer wieder was falsch zu machen. Entweder hat das komplette WAN und das LAN Zugriff oder gar keiner mehr.

Hier einige Auszüge aus der configs:

httpd.conf:
----------
AccessFileName .htaccess
<Directory />
Options FollowSymLinks -Indexes
AllowOverride None
Order deny,allow
Deny from all
Satisfy all
</Directory>

<Directory "D:/httpd/htdocs">

Options -Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

</Directory> [...snip...]
---------

.htaccess
----------

AuthType Basic
AuthName "test"
AuthUserFile "d:/htpd/secret/.htpasswd"
Require valid-user
----------

System: AMD 2000+/1024ram/WinXP
Apache: 2.2.3 / PHP 4.4.4 / ActivePerl 5.5.8 / MySQL 5

Jegliche Suche in diversen HowTo's und Foren war bisher erfolglos...

Bestimmt überseh ich was im Detail, nach 6 Stunden grübelei :-)

Bis denne,

Jörg
Chummer76
 
Posts: 2
Joined: 24. November 2006 22:53

Postby Wiedmann » 25. November 2006 00:31

Code: Select all
<Directory "D:/httpd/htdocs">
...
AllowOverride None
...
</Directory>

Damit kannst du dann in deinem htdocs keine ".htaccess"-Datei mehr benutzen.

Allerdings weist du ja eigentlich was dort hingehört:
Eigentlich sollte bei AllowOverride AuthConfig in der <Directory> Section
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Chummer76 » 25. November 2006 02:35

Hoppla... das war meine Schuld, da hab ich was falsch gepostet... Klar soll im "Stamm" keine .htaccess liegen, sondern in "D:/httpd/htdocs/[Verzeichnis]/"

Klar steht [Verzeichnis] für einen Ordner unter dem Web-Root der
geschützt werden soll. Kleines Versehen :-)

----------
<Directory "D:/httpd/htdocs/[Verzeichnis]">

AuthBasicAuthoritative On

Options +Indexes FollowSymLinks
AllowOverride FileInfo AuthConfig Limit
Order deny,allow
Deny from all
</Directory>
-----------

Bringt mir da satisfy was, denn es erscheint nach wie vor kein http_auth
Fenster.

Ich hatte auch schon die Idee mit einem Port der vllt geforwardet werden
muss, aber in den Docs für HTTP_Auth find ich auch nur Standard 80.

Herzlichen Dank überigens noch für deine wirklich schnelle Antwort !

Gruß Jörg
Chummer76
 
Posts: 2
Joined: 24. November 2006 22:53


Return to Apache

Who is online

Users browsing this forum: No registered users and 8 guests