Radius Authentifizierung mod_auth_radius, mod_auth_xradius

Alles, was den Apache betrifft, kann hier besprochen werden.

Radius Authentifizierung mod_auth_radius, mod_auth_xradius

Postby kgbschnik » 23. November 2006 11:51

Hallo,

in einer Testumgebung wurde ein Apache2 sowie ein Windows Radius-Server aufgesetzt. Nun sollen sich User die Webseiten aufrufen am Radius authentifizieren. Nach meinen Recherchen benötigt Apache2 ein Radius-Modul.

Ich schaffe es einfach nicht dieses einzubinden.

1. Versuch:
http://www.freeradius.org/mod_auth_radius/
Fehler: Datei configure nicht gefunden obwohl ich in /etc/apache2/ den Befehl ausführe.
apxs bringt ebenfalls Fehlermeldungen

2. Versuch:
http://www.outoforder.cc/projects/apach ... dius/docs/
Hier erhalte ich nach Eingabe des Befehls

Code: Select all
./configure --with-apxs=/usr/bin/apxs --with-apr-memcache=/usr/local/apr


als Fehlermeldung, dass meine Apacheversion nicht >=2.0.40 ist und Apache 2.0 nicht gefunden wurde. ABER:
Code: Select all
Apache2 -v
Server version: Apache/2.0.54
Server built: Jul 28 2006 09:04:55


Weiß jemand was ich machen kann? Benötige ich das Modul wirklich, um die PHP-Radiusfunktionen zu verwenden?

Kennt jemand andere Realisierungsmöglichkeiten?
kgbschnik
 
Posts: 5
Joined: 23. November 2006 11:36

Postby Wiedmann » 23. November 2006 13:41

Benötige ich das Modul wirklich, um die PHP-Radiusfunktionen zu verwenden?

Nein. In dem Fall brauchst du natürlich eine entspr. PHP-Extension und kein Apache-Modul.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kgbschnik » 23. November 2006 14:37

Wiedmann wrote:
Benötige ich das Modul wirklich, um die PHP-Radiusfunktionen zu verwenden?

Nein. In dem Fall brauchst du natürlich eine entspr. PHP-Extension und kein Apache-Modul.


Danke das hat mich schonmal vorangebracht. Schade um die Zeit, die ich wegen des Moduls verbraucht habe.

Ich habe jetzt das hier dazu gefunden: http://www.php-homepage.de/manual/ref.radius.php

Da steht jetzt:
Installation

Howto install the package?
untar the package (usually into php4/ext)

Wo finde ich das package? Ist es das richtige?
kgbschnik
 
Posts: 5
Joined: 23. November 2006 11:36

Postby Wiedmann » 23. November 2006 14:45

Da in der Einführung im Manual ja steht das dies ein PECL Paket ist, würde ich bei PECL nachschauen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby deepsurfer » 23. November 2006 14:54

chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby kgbschnik » 24. November 2006 08:30

deepsurfer wrote:http://community.apachefriends.org/f/viewtopic.php?t=6970&highlight=radiusserver


Danke, genau das ist die Seite auf die man über Suchmaschinen andauernd stößt...leider kann ich kein ./configure ausführen, weil in dem Apache-root verzeichnis keine configure Datei liegt...

Ich habe jetzt eine PHP-Extension installiert...die Authentifizierung klappt immer noch nicht. Beim Radius wird aber auch nichts geloggt.

Wie kann man den da noch troubleshooting durchführen? Sehe ich am Apachen, ob der Webserver an den Radius einen Request schickt?
kgbschnik
 
Posts: 5
Joined: 23. November 2006 11:36

Postby Wiedmann » 24. November 2006 12:54

Sehe ich am Apachen, ob der Webserver an den Radius einen Request schickt?

Wieso der Webserver, ich dachte du willst das in PHP machen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to Apache

Who is online

Users browsing this forum: No registered users and 3 guests