Apache2 unterSuse8.2

Alles, was den Apache betrifft, kann hier besprochen werden.

Apache2 unterSuse8.2

Postby Dragon » 15. August 2003 23:27

Hi..

ich habe irgenwie ein grundlegendes problem...und ich weiss nun auch nicht genau ob das psting hier her gehört...

ich habe auf meinem Suse 8.2 Prof den Apache 2,samba,ftp installiert und zum laufen gebracht..(version auf der CD)

Nun meine frage: ich hab eine eigene hompage erstellt unter html und suse hat dafür ein extra verzeichnis im Wurzelverzeichnis ebenso für den ftp..
wie und was schiebe ich in welches verzeichnis für die html seite ?Muss ich meine webseite in php4 ummodeln?da ich webmin nicht installiert bekomme(suse weigert sich)was und wie muss ich das mit der sicherheit machen?
in der suse doku ist nichts beschrieben..

das system besteht aus 2 windoof 2000 rechnern und dem suse als server und sind alle an einem Router,sie finden sich alle und der zugriff mit samba geht auch.
nur online gehen kann ich nich mit dem server

könnt ihr mir bitte helfen?
Dragon
 
Posts: 6
Joined: 15. August 2003 13:46
Location: Lindau/Bodensee

Postby Pc-dummy » 16. August 2003 09:28

Hi

Das ist der grosse Nachteil einer Normalen installation, mann weis nicht wo was ist alles liegt irgendwo im Wurzelverzeichnis!

So jetzt aber zu deinem Prob.:

Zu erst müssen wir mal deine httpd.conf suchen (die httpd.conf ist die einstellungsdatei zum Apache):

ich schätzt mal sie ist unter /etc/httpd.conf wenn nicht updatedb && locate httpd.conf!

wenn du sie gefunden hast dann führst du diesen befehl aus grep DocumentRoot <config>, dort wirt dann wahrscheinlich DocumentRoot /usr/www oder DocumentRoot /var/www stehen.

Jetzt wecheselst du zu dem Pfad des DocumentRoot und kopierst dorthin deine html seiten, deine start-seite bennenst du index.html.

Jetzt noch Testen :)
Wenn du eine Desktopumgebung installiert hast rufst du mit einem belibigen Browser http://localhost auf wenn nicht lynx http://localhost

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Dragon » 20. August 2003 18:54

Hi PC-Dummy..:-)

Vielen dank für die hilfe hat gefunzt...:-)

Suse 8.2 hat nämlich im wurzelverzeichnis ein verzeichnis das sich "srv"
nennt dort wiederum sind verzeichnisse "www" in dem nur cgi dateien sind und ein ftp verzeichnis.

was muss ich noch alles einstellen das ich meine seite sicher machen kann gegen copieren und nur gegen passwort diese seite betreten werden kann.. da auf diesen server ein Internet shop soll weiss ich nun nicht was ich weiter tun soll...
der server sollte dann über dyndns.org erreichbar sein... kann mir bitte da jemand helfen?

danke

Dragon
Dragon
 
Posts: 6
Joined: 15. August 2003 13:46
Location: Lindau/Bodensee

Postby Pc-dummy » 20. August 2003 23:03

HI

Hey ich wohn auch in diesem Drei-Länder eck :)

Hmm

wegen passwd: im forum nach .htaccess suchen :)

Wie meinst du schützen gegen kopieren?

Achja für einen shop solltest du ssl aktivieren/installieren oder gleich das lampp packet installieren dort ist alles vorinstallier und alles ist in einem ordner zu finden :)

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Dragon » 21. August 2003 00:02

Hi PC-Dummy....:-)

Du wohnst in Feldkirch?.. das is nu nicht wirklich weit weg von mir...

ich hab im mom eigentlich ein anderes problem.. mir hat irgend wie mein Suse geplättet und ich musste es neu installieren.. (scheiss abhängigkeiten)

das mit der vorkonfigurierten lampp is so eine sache.. woher weiss denn dann noch was ich tue als anfänger..? :twisted:

Aber wenn de lust hast kannst mich in Lindau besuchen kommen..auf kaffee und pizza heute am donnerstag... :) ich hab gerade urlaub und mir is mehr oder weniger langweilig... :D
Wenn besuch kommt freu ich ich mich immer...

Gruss Dragon
Dragon
 
Posts: 6
Joined: 15. August 2003 13:46
Location: Lindau/Bodensee

Postby Dragon » 22. August 2003 12:17

Morgen PC_Dummy...:-))

also ich habe die HP repariert neu generiert und unter windoof funzt alles...

dann hab ich mir die daten geschnappt und apache gestartet...browser gestartet.. seite funktioniert aber irgend wie kann er die gifs nich anzeigen...

d.h so ziemlich alle pics werden nicht dargestellt.. was nun... fehlt da irgend wie ein modul zum anzeigen?

Dragon
Dragon
 
Posts: 6
Joined: 15. August 2003 13:46
Location: Lindau/Bodensee

Postby Pc-dummy » 22. August 2003 12:54

ne

gug dir mal an ob der pfad in der html überhaupt richtig is
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Dragon » 23. August 2003 12:29

Hi... :)

Also.. ich hab alle dateien in den ordner usr/www/localhost/html rein kopiert ..
auch die index htm ist dort anwesend.... habe ich doch wieder was falsch gemacht...? :oops:

Dragon
Dragon
 
Posts: 6
Joined: 15. August 2003 13:46
Location: Lindau/Bodensee

Postby Pc-dummy » 23. August 2003 15:15

hi Dragon

Nein hast du nicht!

Schau dir den html-quelltext an und schau dort ob die pfadangaben zu den bildern überhaupt richtig sind!

MFG
Pc-Dummy

P.s.: ich bin im ICQ online auch wenn da unten nen scheiss steht!
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Dragon » 29. August 2003 00:42

Hi PC-Dummy...:-)

Also....

wegen der pics... es liegt allein an der gross/klein Schreibung... :oops:

Habe nun auf dem Server apache deinstalliert und xampp installiert die .conf dateien eingefügt die wir konfiguriert hatten und es geht alles... :)

danke für deine hilfe ... :wink:

Gruss Dragon
Dragon
 
Posts: 6
Joined: 15. August 2003 13:46
Location: Lindau/Bodensee


Return to Apache

Who is online

Users browsing this forum: No registered users and 8 guests