rewrite funktioniert nicht

Alles, was den Apache betrifft, kann hier besprochen werden.

rewrite funktioniert nicht

Postby nubis » 18. October 2006 10:10

Hallo,

ich habe ein kleines Problem mit dem mod rewrite.

Ich benutze XAMPP for Linux 1.5.4a, wo auch rewrite aktiviert ist.

In meiner .htaccess Datei steht folgendes:
Options +FollowSymLinks
RewriteEngine on
RewriteRule test/(.*)/(.*)/$ test.php?$1=$2

Die test.php Seite:
<?php
echo "Ein Test";
echo $test2;
?>

Beim Aufrufen mit http://www.meinedomain.de/test/test2/222/ wird aber leider nur "Ein Test" angezeigt und nicht der Wert der Variable. Warum??

Gruss Franko
nubis
 
Posts: 5
Joined: 14. October 2005 08:43

Postby deepsurfer » 18. October 2006 11:11


Bei mir kommt "Server nicht gefunden" !!

wird aber leider nur "Ein Test" angezeigt und nicht der Wert der Variable. Warum??

Solange die Variable "$test2" nicht gefüllt wird kann dir das Echo auch nicht ausgeben.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby nubis » 18. October 2006 11:20

$test2 sollte ja eigentlich durchs rewrite gefuellt werden.

Aber auch soetwas $test2 = $_GET["test2"]; funktioniert nicht.
nubis
 
Posts: 5
Joined: 14. October 2005 08:43

Postby copclerk » 24. October 2006 11:03

wenn ich den mod_rewrite aktiviere, startet mein apache nicht mehr!?
im error.log wird aber kein fehler gemeldet, wo könnte ich den fehler suchen?
-------------------------------
Nach einem Jahr gebe ich mir selbst die Antwort:
alte xampp deinstallieren und neuste version installieren.
copclerk
 
Posts: 10
Joined: 24. October 2006 08:59


Return to Apache

Who is online

Users browsing this forum: No registered users and 5 guests